php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17128 lstat (mis)behaves exactly like stat
Submitted: 2002-05-09 16:03 UTC Modified: 2002-07-02 16:29 UTC
From: Andrew dot Rice at inGenesis dot net Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 4.2.0 OS: Debian GNU/Linux 2.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Andrew dot Rice at inGenesis dot net
New email:
PHP Version: OS:

 

 [2002-05-09 16:03 UTC] Andrew dot Rice at inGenesis dot net
lstat tracks through symbolic link and returns the permission mode of the actual file, rather than the link itself.
fileperms also seems to be affected.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-09 16:42 UTC] Andrew dot Rice at inGenesis dot net
is_link is also broken
 [2002-07-02 16:29 UTC] sterling@php.net
thanks for the laugh...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jun 22 13:01:23 2021 UTC