php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17125 Can't connect to socket on domain starting with a digit
Submitted: 2002-05-09 12:58 UTC Modified: 2002-07-01 17:09 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: len at sendmail dot ru Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.1.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: len at sendmail dot ru
New email:
PHP Version: OS:

 

 [2002-05-09 12:58 UTC] len at sendmail dot ru
Hello, here's my problem:

I am on a site with a domain name starting with a digit. When I try to establish a socket connection to this very site from a script residing on this very site, it doesn't establish connection.

I do it using a standard example from fsockopen() man page. All the other cases work just file, but this one fails.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-09 13:04 UTC] jan@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".


I tested this with 24inch.org and 123.org with the example from http://php.net/fsockopen. Everything works as expected. Maybe you can be a bit more verbose.
 [2002-05-09 13:28 UTC] len at sendmail dot ru
Ok, here's more info:

this script:
http://www.abcda.com/fun/sock.php   tries to open a socket connection to the server.

Here's its source:

<?php
if (isset($go)) {
$fp = fsockopen ($url, 80, $errno, $errstr, 30);
if (!$fp) {
   echo "Error: $errstr ($errno)";
} else {
   echo "Opened";
}
}
?>
<form action=<?php echo $PHP_SELF ?> method=post>
<input type=text name=url>
<input type=hidden name=go value=1>
<input type=submit name=submit value=connect>
</form>

now, if you enter www.9o9o.com in the field which is my hoster, you get a fsockopen timeout, it just doesn't connect.
 [2002-07-01 17:09 UTC] jason@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

up your timeout, it has nothing to do with numbers in the string 9o9o is slow on connect

-jason 
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 08:01:23 2020 UTC