php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17124 install.txt (php.exe vs php-cli.exe)
Submitted: 2002-05-09 12:39 UTC Modified: 2002-05-10 14:32 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: thenry at mysideproject dot com Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.2.0 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: thenry at mysideproject dot com
New email:
PHP Version: OS:

 

 [2002-05-09 12:39 UTC] thenry at mysideproject dot com
I believe there is an error in the php install.txt.

-Using the traditional php as a CGI binary, it states to add the following line to your conf file on a Apache server:

Action application/x-httpd-php "/php/php.exe"

However, in the new build of php 4.2.0 using the zip package, there is no "php.exe" in the php directory.  There is only a php-cli.exe, the php.exe is actually located in the sapi directory.

I am having tremendous amounts of trouble installing the new php build on my Apache server, whereas the previous php build runs fine on my portable laptop running the same server.  I am getting both 404 file not founds, and 500 errors.  I've also checked the Apache error log file and it states:

[Thu May 09 12:19:54 2002] [error] [client 127.0.0.1] script not found or unable to stat: D:/Apache/php/php.exe, referer: http://localhost/

Todd Henry
Portland, ME

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-10 04:43 UTC] sander@php.net
You need to use the php.exe in the /sapi directory, php-cli.exe should not be used in with a webserver.
I've already updated install.txt to reflect these changes.
 [2002-05-10 14:26 UTC] thenry at mysideproject dot com
Ok, now I updated my conf file for my Apache Server to the following:

Action application/x-httpd-php "/php/sapi/php.exe"

I restarted the server, then tried accessing one of my php files.  I get the following in a windows alert box. "php.exe - Unable To Locate DLL", Thy dynamic link library php4ts.dll could not be found in the specified path d:\Apahce~1\php\sapi ... (screen shot here http://www.mysideproject.com/dump/php-error.gif)

This is because the php4ts.dll file is located in the php directory not the Sapi directory.  So now what?

On top of that, I thought I would cross reference the install.txt located in the zip file to the one you have on the website at http://cvs.php.net/co.php/php4/win32/install.txt

The install.txt online says to use the following Action application:

Action application/x-httpd-php "/php/php-cgi.exe"

I believe that is a documentation error as well.  Confusing none the less, any other suggestions?  I think I will double back to release 4.1.2
 [2002-05-10 14:32 UTC] thenry at mysideproject dot com
Ok, I fixed that error as well by simply copying php4ts.dll to the sapi directory and now this php build works fine!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 13:01:47 2020 UTC