php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17087 No SID constant in PHP 4.2.0-win32
Submitted: 2002-05-08 02:26 UTC Modified: 2002-05-08 02:46 UTC
From: chros at freemail dot hu Assigned:
Status: Closed Package: Session related
PHP Version: 4.2.0 OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chros at freemail dot hu
New email:
PHP Version: OS:

 

 [2002-05-08 02:26 UTC] chros at freemail dot hu
The problem is, that I couldn't transmit the SID constant in URL under PHP 4.2.0 win32! 
(the session_name() . "=" . session_id() works) 

for example: header("Location: temp.php?" . SID); 
<a href="temp.php?<?php echo SID ?>">temp</a> 

or a much simplier example: within a page:
<?php
   start_session();
   echo SID;
?>

Nothing happens .... 

Is it a bug or just I'm stupid (I forgot something with the variable scope) ??? 


OS: WinXP 
Apache with PHP CGI
php4.2.0 win32 !!! 

register_globals off; 
auto_tans_sid on;

chros

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-08 02:29 UTC] derick@php.net
This is indeed a bug, and it's fixed in CVS. You can try the latest stable snapshot from snaps.php.net/win32 or wait for 4.2.1 which will be released monday.

Derick
 [2002-05-08 02:46 UTC] chros at freemail dot hu
thanx for the quick answer !!

I'll wait till monday ...

chros
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Feb 09 06:05:49 2023 UTC