php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17042 Problem with running php under apache control
Submitted: 2002-05-06 09:02 UTC Modified: 2002-05-06 09:05 UTC
From: yeyo at wp dot pl Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: Free BSD 4.5 RELEASE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yeyo at wp dot pl
New email:
PHP Version: OS:

 

 [2002-05-06 09:02 UTC] yeyo at wp dot pl
I've previous compiled Apache ver. 2.0.35

PHP ver 4.2.0: 
	
	./configure --witch-mysql --witch-apxs=/path/to/apxs 
	make
	make install


I've added to httpd.conf this line:
	
	"LoadModule php4_module        modules/libphp4.so"


During I was starting http's daemon  (with ./apachectl startssl or ./httpd) it crashes with message: 


Syntax error on line 217 of /usr/apache/conf/httpd.conf:
Cannot load /usr/apache/modules/libphp4.so into server: /usr/apache/modules/libphp4.so: Undefined symbol "pthread_getspecific"
./apachectl startssl: httpd could not be started

What's going on ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-06 09:05 UTC] derick@php.net
You need another module for this, apache2filter.dll is for use with yApache 2.

Derick
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 00:03:37 2021 UTC