php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1701 PHP not closing invalid persistent connections
Submitted: 1999-07-13 10:23 UTC Modified: 2001-02-10 15:21 UTC
From: q at onthenet dot com dot au Assigned:
Status: Closed Package: mSQL related
PHP Version: 3.0.11 OS: FreeBSD 3.2-RELEASE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: q at onthenet dot com dot au
New email:
PHP Version: OS:

 

 [1999-07-13 10:23 UTC] q at onthenet dot com dot au
When using PHP as a module in apache, and connecting to mSQL using local domain sockets. If a connection is made using msql_pconnect() and the mSQL database goes away, when it returns all subsiquent mSQL operations will fail when using this persistent connection. The only way to fix this situation is to restart apache. The problem is that upon calling msql_pconnect() after mSQL has been restarted the existing (now invalid) handle is returned. Either support should be added to detect the termination of the connection (if this is possible) or an msql_pclose() function should be added so that a persistent connection can be explicitely closed when it becomes invalid.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-04 22:34 UTC] hholzgra@php.net
do current versions of php still show this bug?
 [2001-02-10 15:21 UTC] jimw@php.net
no feedback, closing.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 12:03:36 2021 UTC