php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16999 problem viewing PHP script with netscape
Submitted: 2002-05-04 00:04 UTC Modified: 2002-05-06 15:04 UTC
From: guenther at wsu dot edu Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: Tru64 5.1A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: guenther at wsu dot edu
New email:
PHP Version: OS:

 

 [2002-05-04 00:04 UTC] guenther at wsu dot edu
Hi, I have a problem in that Netscape browsers are unable to view a php script. This works with MSIE, but Netscape just prints the source of a php to the screen like a text file instead of processing the php. My installation is:

tru64 5.1A
apache 2.0.35
php 4.2.0
gcc 3.0.3

I compiled apache and php without any event and they installed fine and the server is up and running. The code of the php is simple:

cat: cannot open forms.cgi
# cat forms.php
<html><head><title></title></head><body>

<form action="action.php3" method="POST">
Your name: <input type=text name=name>
You age: <input type=text name=age>
<input type=submit>
</form> 
</body>
</html>

This shows perfectly with MSIE but just the above text with Netscape 6 or netscape 4 browsers.

I did try this with the alpha version of apache 2.0.36 but it had the same results. Any idea why there is a problem with netscape??

Note that the same script above works fine when viewed from a netscape browser on an older server running

apache 1.3.?
tru64 4.0g
php 4.1.?

-- Dean


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-06 14:59 UTC] guenther at wsu dot edu
In the httpd.conf I had 
     <IfModule mod_php4.c>
wrapped around my AddType. So, it wasn't getting read. 
Its ok now. Please close this report. 

-- Dean
 [2002-05-06 15:04 UTC] mfischer@php.net
Bogus.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 01:03:34 2021 UTC