php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16967 FATAL: emalloc(): Unable to allocate
Submitted: 2002-05-02 10:36 UTC Modified: 2002-06-04 01:00 UTC
Votes:13
Avg. Score:4.7 ± 0.6
Reproduced:12 of 12 (100.0%)
Same Version:6 (50.0%)
Same OS:9 (75.0%)
From: info at i-plaats dot nl Assigned:
Status: No Feedback Package: Unknown/Other Function
PHP Version: 4.2.0 OS: Redhat Linux 7.2 (Intel)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at i-plaats dot nl
New email:
PHP Version: OS:

 

 [2002-05-02 10:36 UTC] info at i-plaats dot nl
Hi i have installed php 4.2.0, apache 1.3.24 and a lot of other software.

config php:

'./configure' '--with-config-file-path=/usr/local/apache/conf' '--with-apxs=/usr/local/apache/bin/apxs' '--with-mysql=/usr/local/mysql' '--with-imap=../imap' '--with-zlib-dir=../zlib' '--with-gd=../gd' '--with-png-dir=../libpng' '--with-jpeg-dir=../jpeg' '--with-openssl' '--enable-ftp' '--enable-shmop' '--enable-xml' '--enable-track-vars' '--enable-magic-quotes' '--with-curl-dir=/usr/local/curl' '--prefix=/usr/local/php' '--enable-sockets' '--with-system-regex'


problem:

I have used the latest version of phpMyAdmin but when i try to visit it with my browser i get a 404 and my error_log says:

[Thu May 2 11:17:45 2002] [notice] Apache/1.3.24 (Unix) mod_gzip/1.3.19.1a mod_ssl/2.8.8 OpenSSL/0.9.6b mod_throttle/3.1.2 PHP/4.2.0 mod_perl/1.26 configured -- resuming normal operations
[Thu May 2 11:17:45 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)
FATAL: emalloc(): Unable to allocate -295992 bytes
FATAL: emalloc(): Unable to allocate -295992 bytes
FATAL: emalloc(): Unable to allocate -295992 bytes
FATAL: emalloc(): Unable to allocate -294200 bytes
FATAL: emalloc(): Unable to allocate -294200 bytes
FATAL: emalloc(): Unable to allocate -295352 bytes
FATAL: emalloc(): Unable to allocate -524728 bytes
FATAL: emalloc(): Unable to allocate -524728 bytes

Can anyone help me?

Note: i'm dutch so sorry for my language usage

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-02 10:39 UTC] derick@php.net
Can you try 4.2.1rc1 from www.php.net/~derick ?

(en het engels is prima hoor :)

Derick
 [2002-05-02 11:14 UTC] info at i-plaats dot nl
I have downloaded http://www.php.net/~derick/php-4.2.1RC1.tar.bz2 and i will try this
 [2002-05-02 11:48 UTC] info at i-plaats dot nl
ik heb php versie 4.2.1RC1 geinstalleerd zoals derek voorstelde maar ondanks dat krijg ik nog steeds dezelfde fout. Ik heb het weer getest en phpSysInfo enzo werken wel allemaal alleen phpMyAdmin tot nu toe nog niet.

Het probleem is er dus nog steeds.

Is het raadzaam om alles opnieuw te installeren?

------------------------------

i have installed it but the problem stills exists.

phpSysInfo and other scripts/pages works fine but phpMyAdmin doesn't still work well.

So the problem still exists.

Is it smart to reset my hole system and start over with installing?
 [2002-05-02 13:34 UTC] msopacua at idg dot nl
Could you check if the patch available below fixes your problem?

http://sourceforge.net/tracker/index.php?func=detail&aid=547030&group_id=23067&atid=377410
 [2002-05-02 13:57 UTC] info at i-plaats dot nl
Damn too late,
i have just started to reset my system

but if the error starts again i will try the patch

thnx anyway
 [2002-05-02 13:57 UTC] info at i-plaats dot nl
Damn too late,
i have just started to reset my system

but if the error starts again i will try the patch

thnx anyway
 [2002-05-03 03:14 UTC] derick@php.net
Can you disable all other modules to apache except PHP... I think something conflicts.

Derick
 [2002-05-03 09:31 UTC] info at i-plaats dot nl
I have reinstalled my hole system, with all software but php version 4.1.2 instead of 4.2.0 and it works!

I have no idea what the problem was but it is gone :)

Thanx everyone !!
 [2002-05-04 00:16 UTC] yohgaki@php.net
Strange. Make this report bogus.


 [2002-05-04 00:22 UTC] yohgaki@php.net
Oops, you've down graded PHP.
Could you try snapshot see if problem is still there or not?

http://snaps.php.net/

 [2002-05-12 09:42 UTC] eodabas at progen dot com dot tr
I have the same problem with php 4.2.0, Redhat 7.2, apache 1.3.22 (mod_perl/1.26 mod_throttle/2.11 PHP/4.2.0 FrontPage/4.0.4.3 mod_ssl/2.8.5 OpenSSL/0.9.6b).

here is the configuration line

./configure --with-apxs=/usr/local/psa/apache/bin/apxs\
 --enable-calendar\
 --enable-track-vars\
 --enable-ftp\
 --enable-exif\
 --disable-debug\
 --enable-pear\
 --with-system-regex\
 --with-pcre\
 --with-imap\
 --with-mod_charset\
 --without-imap-ssl\
 --with-openssl\
 --with-config-file-path=/usr/local/psa/apache/conf\
 --with-swf=/usr/local\
 --with-mysql=/usr/local/psa/mysql\
 --with-mcrypt=/usr/local\
 --with-curl-dir=/usr/local/include/curl\
 --with-java\
 --with-zip=/usr/local\
 --with-dom=/usr/local\
 --with-tiff-dir=/home/admin/apache/tiff-v3.5.7\
 --with-gd=/home/admin/apache/gd-2.0.1\
 --enable-gd-native-ttf\
 --enable-gd-imgstrttf\
 --with-jpeg-dir=/usr/local\
 --with-gif-dir=/usr/local\
 --with-zlib-dir=shared\
 --with-png-dir=/usr/local\
 --with-freetype-dir=/home/admin/apache/freetype-2.0.6/\

regards
 [2002-06-04 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-09-05 07:00 UTC] arnout at argeweb dot nl
I'm having the same problem with serveral scripts. 
I'm not getting any 404s. The output to the browser just stops in the middle of a script without any warnings or errors, and the error_log says:

FATAL:  emalloc():  Unable to allocate -458296 bytes
FATAL:  emalloc():  Unable to allocate -417336 bytes
FATAL:  emalloc():  Unable to allocate -459576 bytes
FATAL:  emalloc():  Unable to allocate -417336 bytes
FATAL:  emalloc():  Unable to allocate -418616 bytes



My version:

PHP 4.2.2
Apache/1.3.26
Mysql 3.23.52
Redhat 7.2
Zend Engine v1.2.0

'./configure' '--with-mysql=/usr/local/mysql' '--enable-versioning' '--enable-track-vars=yes' '--enable-url-includes' '--enable-sysvshm=yes' '--enable-sysvsem=yes' '--enable-magic-quotes' '--with-system-regex' '--with-zlib' '--with-pdflib=/usr/local' '--with-xml' '--with-iconv=/usr/local' '--enable-ftp' '--with-imap' '--with-pdflib=/usr/local' '--with-gd=/usr' '--with-freetype-dir=/usr/local' '--enable-gd-native-ttf' '--enable-gd-imgstrttf' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-swf=/usr/local/src/libswf/dist/' '--with-ming' '--with-xslt-sablot=/usr/local' '--enable-xslt' '--with-imagick' '--with-apxs=/usr/local/apache/bin/apxs'
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 09:03:34 2021 UTC