php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16869 Squirrelmail, wrong directory
Submitted: 2002-04-27 04:34 UTC Modified: 2002-04-27 06:51 UTC
From: japs at adm dot ku dot dk Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.2.0 OS: Linux Mandrake 8.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: japs at adm dot ku dot dk
New email:
PHP Version: OS:

 

 [2002-04-27 04:34 UTC] japs at adm dot ku dot dk
Use of Squirrelmail version 1.0.6 and 1.2.5 fails together with PHP 4.2.0. Squirrelmail is installed at /usr/apache/htdocs/squirrelmail.

During the initial call of Squirrelmail (http://my.server/squirrelmail) the Apache 1.3.24 error log says: 
File does not exist: /usr/apache/htdocs/src/login.php

PHP version 4.1.2 (and earlier) on the other hand works correctly, and finds the requested document at the proper location:

/usr/apache/htdocs/squirrelmail/src/login.php

Jan P. Sorensen

----------------------------------------------

PHP configuration:

  ./configure --with-apache=../apache_1.3.24 --enable-track-vars --with-mysql



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-27 06:03 UTC] mfischer@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php
 [2002-04-27 06:45 UTC] japs at adm dot ku dot dk
This was not meant as a support question.

It was intended to inform you that a change has occured from PHP 4.1.2 to 4.2.0 which causes identical versions of Squirrelmail to fail.

Jan P. Sorensen
 [2002-04-27 06:51 UTC] mfischer@php.net
Is saw your point, but you have to understand that this is rather useless information as this is a bug system for PHP and not for every piece of software out there written *in* PHP. If you want to report a bug concerning PHP, you have to be specific about the actual problem, give reproduceable examples, etc. and not just tell 'software xy doesn't work anymoer after the upgrade'. Who says this software is 100% error free? I hope you see the point of this bug reporting system.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 20:03:33 2021 UTC