php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16816 PHP opens more connections as allowed
Submitted: 2002-04-25 04:35 UTC Modified: 2002-10-27 19:00 UTC
Votes:2
Avg. Score:4.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: hofmann at isl dot org Assigned:
Status: No Feedback Package: Sybase (dblib) related
PHP Version: 4.1.2 OS: Linux 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hofmann at isl dot org
New email:
PHP Version: OS:

 

 [2002-04-25 04:35 UTC] hofmann at isl dot org
My sybase config for php is as follows:

sybase.allow_persistent =       On
sybase.max_persistent   =       5
sybase.max_links          =       5

Also I am using phplib database classes - which are based on pconnect().
The problem now is that after a short time there are 15 or more PHP processes within the sybase database!
The result is that another Delphi Programm can not longer access the same database, because it can not open a connection when all connections are used by php! (increasing the max num of connections within the sybase db is no real solution to this!)
I wonder about the BROKEN_SYBASE_PCONNECTS define within the source code - is there a known problem which I haven't found within the web/news?

Thanks for help

Kai Hofmann

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-09 22:20 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-10-27 19:00 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2004-11-17 13:21 UTC] nicolas dot karageuzian at clubmed dot com
I experienced the same problem using PHP 4.3.3 on AIX 4.3.3 or Solaris 8 with a DB2/zOS database.
I'm not using --with-ibm-db2 but the unixODBC driver over the CLI interface.
When i run a loadTest, i can see on my SGBD more connexions from the httpdaemon/phpdbuser than allowed in php.ini.
Is there any patch or config i missed to correct this ?
I noticed the following as well, it could be linked to my problem :
the "Active Persistent Links" and "Active Links" sections from phpinfo() always displays 0 in any case.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jul 03 11:01:25 2020 UTC