php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16802 php4apache.dll problem
Submitted: 2002-04-24 14:01 UTC Modified: 2002-04-24 15:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: seagarwu at pchome dot com dot tw Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.1.2 OS: Windows2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: seagarwu at pchome dot com dot tw
New email:
PHP Version: OS:

 

 [2002-04-24 14:01 UTC] seagarwu at pchome dot com dot tw
When I have installed :(follow book steps)
1.MySQL(mysql-3.23.49-win.zip)
2.PHP(php-4.0.5-Win32.zip)
3.Apache(apache_1.3.19-win32-no_src-r2.msi)
and configurated:
1.c:\php\php.ini-optimized: 
  ;extension=php_imap.dll -> extension=php_imap.dll
2.C:\Program Files\Apache Group\Apache\conf\httpd.conf:
  (1)add in: 
     LoadModule php4_module c:/php/sapi/php4apache.dll
     AddType application/x-httpd-php .php .php3
     AddType application/x-httpd-php-source .phps
  (2)modify:
     DirectoryIndex index.html ->
     DirectoryIndex index.html index.php3 index.php 
                    index.pthml
  (3)DocumentRoot "C:/Program Files/Apache Goup/Apache/
                   htdocs" ->
     DocumentRoot "D:\HTML"
  (4)Directory "C:/Program Files/Apache Group/Apache/
                htdocs" ->
     Directory "D:/HTML/"
finally:
  run the Apache Server, and show the message:
  "Cannot load c:/php/sapi/php4apache.dll into server."

Can you solve my problem?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-24 15:05 UTC] dennis dot decoene at moveit dot be
I have exactly the same configuration and exactly the same problem...
 [2002-04-24 15:11 UTC] derick@php.net
You need the apache2filter.dll for apache 2. Not a bug -> bogus.

Derick
 [2002-04-25 00:48 UTC] seagar at cm dot yuntech dot edu dot tw
Where can I download apache2filter.dll and how to setup it?
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 01:03:34 2021 UTC