php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16783 Cant run apache2 with PHP module
Submitted: 2002-04-23 21:42 UTC Modified: 2002-04-23 22:03 UTC
From: superzouz at hotmail dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: Windows XP Professional 5.1.2600
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: superzouz at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-04-23 21:42 UTC] superzouz at hotmail dot com
The following problem is most probably caused by Apache, not PHP, but this report may be useful to you.


_______________Summary: 

After adding the necessary lines in httpd.conf to register the PHP module, Apache service cannot be started.
The Windows event viewer reports:
"The Apache service named  reported the following error:>>> Cannot load C:/PHPmod/sapi/php4apache.dll into server: The specified module could not be found."
But the dll is right where it should be, and with appropriate permissions set!


_______________Details:
Apache version: 2.0.35

As instructed in install.txt on your distribution, 
I added the following lines to the Modules section in httpd.conf:
#----------PHP-------------
LoadModule php4_module c:/PHPmod/sapi/php4apache.dll
AddModule mod_php4.c
AddType application/x-httpd-php .php
#--------------------------

I am using the "c:\PHPmod" directory because c:\php contains the CGI distribution of PHP4.1.1 wich I use with a Xitami Webserver and for processing scripts.

I tried to move the dll around a bit (like in the apache mods directory) and experimented with the path (trying windows slashes, omitting "c:" etc).

Later on, I read the PHP install directions and noticed I hadn't copied php.ini in the windows directory. So I copied php.ini-distr , renamed it and edited the "extension_dir" setting as instructed. But that didn't fix the problem.



Thank you

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-23 21:57 UTC] sniper@php.net
You're using wrong dll. it's called 'apache2filter.dll' and it can be found in the experimental folder in the zip.

 [2002-04-23 22:03 UTC] superzouz at hotmail dot com
Sorry Sorry!
Just found other similar bug reports!
Sorry for wasting your time.
PHP now works with apache2filter.dll
but I had to comment "AddModule mod_php4.c" because Apache complained:
"Invalid command 'AddModule', perhaps mis-spelled or defined by a module not included in the server configuration."
 [2002-04-26 16:44 UTC] luna at enst dot fr
If it can help, I tried to make an installation doc at:
http://137.194.8.83/ATSEC/PHP4Apache2Windows.html
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 02:03:35 2021 UTC