php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16719 tmp_name = none
Submitted: 2002-04-21 07:29 UTC Modified: 2002-04-21 14:27 UTC
From: new353 at hotmail dot com Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.1.2 OS: win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: new353 at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-04-21 07:29 UTC] new353 at hotmail dot com
Win 98, Apache 1.3.24 and Php 4.1.2

print_r ($HTTP_POST_FILES)

tmp_name = none and size = 0



safe_mode = Off, so where did I go wrong ?

thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-21 07:36 UTC] mfischer@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

 [2002-04-21 08:03 UTC] new353 at hotmail dot com
sorry !

I'm trying to do a file_upload with a simple form
and somehow I can't get the file uploaded to the directory.
I tried to print the array ($HTTP_POST_FILES) 
to get some information about what is going wrong 
with my upload and thats when I realized that the
print gave me 'none' for uploaded file tmp_name
and '0' for uploaded file size.

// html
<html>
<body>
<form enctype="multipart/form-data" action="upload.php" 
method="post">
<input type="hidden" name="MAX_FILE_SIZE" value="1000">
Send this file: <input name="userfile" type="file">
<input type="submit" value="Send File">
</form>
</body>
</html>

//php
<?php

print_r ($HTTP_POST_FILES);

// or this

$temp_name = $HTTP_POST_FILES['userfile']['tmp_name'];
$size = $HTTP_POST_FILES['userfile']['size'];

echo ($temp_name);
echo ($size);

?>
 [2002-04-21 14:27 UTC] sniper@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php

If you'd make that MAX_FILE_SIZE value bigger..you might
have a chance..now it only allows uploading of about 1kb 
files. Not a bug.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Feb 25 20:01:24 2021 UTC