|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16671 configuire -with-java and -with-zlib will cause make to fail
Submitted: 2002-04-17 17:45 UTC Modified: 2002-04-22 18:34 UTC
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: PLancashire at Columbia dot com Assigned:
Status: Closed Package: Java related
PHP Version: 4.1.2 OS: Solaris 2.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: PLancashire at Columbia dot com
New email:
PHP Version: OS:


 [2002-04-17 17:45 UTC] PLancashire at Columbia dot com
Environment, Failing configure, Working configure,
partial output from make with failing configure.

Solaris Sparc 2.8 Patchkit as of 5/Apr/2002
Gcc 3.0.3 (Sunfreeware)
binutils 2.11.2 (Sunfreeware)
GNU Make version 3.79.1 (Sunfreeware)
GNU libtool 1.4 (1.920 2001/04/24 23:26:18) (Sunfreeware)
java j2sdk1_3_1_03 (have also tried with stock java1.2)
Zlib 1.1.4 (source)
php 4.1.2

---Failing configure--------------------------------
./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--with-config-file-path=/usr/local/apache/httpd/conf \
--without-mysql \
--with-zlib-dir=/usr/local \
--with-zlib=/usr/local \

---Working configure--------------------------------
./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--with-config-file-path=/usr/local/apache/httpd/conf \
--without-mysql \

---snipped output from make-------------------------
Making all in java
make[2]: Entering directory `/usr/local/build/php-4.1.2/ext/java'
make[3]: Entering directory `/usr/local/build/php-4.1.2/ext/java'
/bin/sh /usr/local/build/php-4.1.2/libtool --silent --mode=compile gcc -I. -I/usr/local/build/php-4.1.2/ext/java -I/usr/local/build/php-4.1.2/main -I/usr/local/build/php-4.1.2 -I/usr/local/apache/include -I/usr/local/build/php-4.1.2/Zend -I/usr/local/include -I/usr/local/build/php-4.1.2/ext/xml/expat -I/usr/j2sdk1_3_1_03/include -I/usr/j2sdk1_3_1_03/include/solaris -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=280 -DMOD_SSL=208108 -DMOD_PERL -DUSE_PERL_SSI -DEAPI -DEAPI_MM -DUSE_EXPAT -I/usr/local/build/php-4.1.2/TSRM -g -O2 -prefer-pic -DJNI_12 -D_REENTRANT '-DJAVALIB="/usr/j2sdk1_3_1_03/jre/lib/sparc/"' -c java.c && touch java.slo
java.c: In function `jvm_create':
java.c:160: parse error before '*' token
java.c:192: `JNI_CreateVM' undeclared (first use in this function)
java.c:192: (Each undeclared identifier is reported only once
java.c:192: for each function it appears in.)
java.c:192: parse error before "JNICALL"
java.c:193: `type name' declared as function returning a function
java.c:193: cast specifies function type
java.c: At top level:
java.c:650: syntax error before "void"
java.c:664: syntax error before "void"
java.c:672: syntax error before "void"
java.c:680: syntax error before "void"
java.c:688: syntax error before "void"
java.c:711: syntax error before "void"
java.c:717: syntax error before "jlong"
java.c:727: syntax error before "jlong"
java.c:738: syntax error before "jlong"
java.c:751: syntax error before "void"
java.c:759: syntax error before "void"
make[3]: *** [java.slo] Error 1
make[3]: Leaving directory `/usr/local/build/php-4.1.2/ext/java'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/build/php-4.1.2/ext/java'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/build/php-4.1.2/ext'
make: *** [all-recursive] Error 1


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-17 18:03 UTC] PLancashire at Columbia dot com
Does the same with 4.2.0RC4
 [2002-04-19 19:07 UTC] Dubravko dot Penezic at SRCe dot hr
It seams to be connected with gcc , I got same message when compiling CURL on Solaris 8 with gcc 3.0.3 ... but using gcc 
2.95.4 isnt create that type of error.
 [2002-04-22 10:33 UTC] PLancashire at Columbia dot com
Well after a few hours I found it to be an include
file for GCC, jni.h in /usr/local/include

The ./configure in creating the Makefile, puts
/usr/local/include BEFORE /usr/local/<java_path>/include.

If you put the -I/usr/local/include after the -I/usr/local/<java_path>/include for
the java option, or put it last like i did and it builds just fine.

The question comes to how to fix ?

The GNU Java puts everything in /usr/local including the
libs, includes etc.

I'm not enough of a Make expert to know how to change
the order.
 [2002-04-22 11:03 UTC]
First, try latest CVS snapshot from
as it has a bit better build system and this kind of 
changes can be made a lot easier there.


 [2002-04-22 11:03 UTC]
 [2002-04-22 17:59 UTC] PLancashire at Columbia dot com
That made it all the way.

I'm just a little worried about running with such an new

Although this box will not be 'production' it will be
a demonstator of how open source can eliminate the stuff
from Redmond WA

 [2002-04-22 18:34 UTC]
So the latest CVS snapshot worked fine? Great.
Now, you could also try PHP 4.2.0 which was just released.
I'm not sure if it will work, but it would be nice to know.

Anyway, I'm closing this report now. We're hoping to get
PHP 4.3.0 out asap too.

PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Jun 07 02:03:36 2023 UTC