php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16670 php 4.1.0, cyrus-imapd.2.0.16, c-client compile-error
Submitted: 2002-04-17 16:33 UTC Modified: 2002-05-21 00:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: achim at altmann dot li Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 4.2.0 OS: linux / redhat 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: achim at altmann dot li
New email:
PHP Version: OS:

 

 [2002-04-17 16:33 UTC] achim at altmann dot li
hallo,

please help, i work many days with the same problem.

I have redhat7.2 system,
with the follows components

cyrus-sasl-1.5.24-23
cyrus-sasl-devel-1.5.24-23
cyrus-sasl-gssapi-1.5.24-23
cyrus-sasl-plain-1.5.24-23
cyrus-sasl-md5-1.5.24-23
imap-devel-2000c-15
and
cyrus-imapd-2.0.16-4

the configure script from php-4.1.0 
is 
./configure \
--with-apxs=/websec/apache/sbin/apxs \
--with-mysql=/usr/local/mysql \
--with-openssl=/usr/local/ssl \
--with-kerberos=/usr/kerberos \
--enable-versioning \
--enable-track-vars \
--with-zlib-dir=/usr/include \
--with-zlib=yes \
--with-jpeg-dir=/usr/include \
--with-tiff-dir=/usr/include \
--with-cyrus \
--with-db \
--with-gdbm=/usr/include \
--with-ndbm=/usr/include \
--with-db3=/usr/include \
--with-db3=/usr/include \
--enable-ftp \
--with-gd=usr/local/src/gd-1.8.4 \
--with-png-dir=/usr/lib \
--with-freetype-dir=/usr \
--with-pspell=/usr \
--with-xpm-dir=/usr \
--with-imap \
--with-imap-ssl=/usr/loca/ssl \
--with-mcrypt=/usr/include \
--with-mm=/usr/local \
--with-gettetxt=/usr/include \
--with-gd  \
--with-ncurses \
--enable-ftp \
--enable-sysvsem \
--enable-sysvshm \
--enable-sockets \
--with-config-file-path=/etc

this run's with no problems

the make phuuuuu make many problems like this

Making all in cyrus
make[2]: Wechsel in das Verzeichnis Verzeichnis ?/usr/local/src/php-4.1.0/ext/cyrus?
make[3]: Wechsel in das Verzeichnis Verzeichnis ?/usr/local/src/php-4.1.0/ext/cyrus?
/bin/sh /usr/local/src/php-4.1.0/libtool --silent --mode=compile gcc  -I. -I/usr/local/src/php-4.1.0/ext/cyrus -I/usr/local/src/php-4.1.0/main -I/usr/local/src/php-4.1.0 -I/websec/apache/include -I/usr/local/src/php-4.1.0/Zend -I/usr/local/ssl/include -I/usr/local/include -I/usr/include/freetype2/freetype -I/usr/include/imap -I/usr/local/mysql/include/mysql -I/usr/include/pspell -I/usr/local/src/php-4.1.0/ext/xml/expat  -DLINUX=22 -DMOD_SSL=208105 -DMOD_PERL -DUSE_PERL_SSI -DUSE_HSREGEX -DEAPI -DEAPI_MM -I/usr/local/src/php-4.1.0/TSRM -g -O2 -prefer-pic  -c cyrus.c
cyrus.c: In function `zm_startup_cyrus':
cyrus.c:88: `IMCLIENT_CONN_NOSYNCLITERAL' undeclared (first use in this function)
cyrus.c:88: (Each undeclared identifier is reported only once
cyrus.c:88: for each function it appears in.)
cyrus.c:88: `CONST_CS_' undeclared (first use in this function)
cyrus.c: In function `zif_cyrus_authenticate':
cyrus.c:271: warning: assignment makes pointer from integer without a cast
cyrus.c:275: warning: assignment makes pointer from integer without a cast
cyrus.c:293: warning: comparison between pointer and integer
cyrus.c:302: warning: comparison between pointer and integer
cyrus.c: In function `zif_cyrus_query':
cyrus.c:467: void value not ignored as it ought to be
make[3]: *** [cyrus.lo] Fehler 1
make[3]: Verlassen des Verzeichnisses Verzeichnis ?/usr/local/src/php-4.1.0/ext/cyrus?
make[2]: *** [all-recursive] Fehler 1
make[2]: Verlassen des Verzeichnisses Verzeichnis ?/usr/local/src/php-4.1.0/ext/cyrus?
make[1]: *** [all-recursive] Fehler 1
make[1]: Verlassen des Verzeichnisses Verzeichnis ?/usr/local/src/php-4.1.0/ext?
make: *** [all-recursive] Fehler 1

please help me, please 


Best reagards

and a lot of thanks

Achim

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-18 06:22 UTC] sander@php.net
Can you try 4.2.0RC4 (from www.php.net/~derick)? And can you try compiling only --with-cyrus and no other extensions?
 [2002-04-18 06:22 UTC] sander@php.net
Can you try 4.2.0RC4 (from www.php.net/~derick)? And can you try compiling only --with-cyrus and no other extensions?
 [2002-04-18 10:31 UTC] achim at altmann dot li
Hallo,
yes i have download 4.1.2 and 4.0.6 , configure and compile.
The problem, i think at this moment is the follow.
When i compile php4.0.6 with the same options zhe comes in the configure-error the meassage "your c-client mot support ssl please remove or recompile them", when i compile without ssl then is all ok. I think at this moment this was the Problem with php4.1.0 i think at the same with 4.2.x.
Ok. i must look was is the error in c-client. But i has him compiles with ssl-support. maby not correct.

Thanks a lot for this moment for
all your help

best reagards
Achim
 [2002-04-18 16:32 UTC] sniper@php.net
Did you or did you not try the RC4? 

 [2002-04-19 07:39 UTC] achim at altmann dot li
Hallo,
Yes i have try RC4. 
I have first compile without all options, was all ok.
At the second i have compile with mysql-support, was all ok.
The next step i have compile with many options but without imap and imap-ssl, cyrus was enable, all was ok. (sorry a little problem was with DOM-support, my library was maby to old).
in the next step i have compiled with mysql, openssl, cyrus, imap and imap-ssl, bull-shit .
Ok. i think the problem is only the c-client.

the biggest crazy step was the follow.
i have compiled php4.0.6 with imap and imap-ssl, the configure say in this moment (was very good) yoer imap support nothing ssl please remove or --without-imap-ssl or so.
i have then configure run und after this compile with cyrus, and imap but without imap-ssl, was very good.

Please look the next, that's crazy !!

I have the compiled php4.1.2 with 
mysql, openssl, cyrus and imap " *** but *** " without imap-ssl.
the configure comes with an error and say

	your c-client is compiled with ssl pleas youse
	imap-ssl

Thanks a lot for your help

and a nice day

Best reagards
Achim
 [2002-04-19 10:25 UTC] sniper@php.net
And what did happen with 4.2.0RC4 ???
And have you always done a clean configure / make
between those different configures?

 [2002-04-19 20:31 UTC] achim at altmann dot li
hallo,
i have compiled php-4.2.0RC4 on a new machine with suse 7.3

i think imap-ssl is ok. but now is the follow error

configure:36521: result: no
configure:36535: error: Sorry, I was not able to diagnose which libmcrypt version you have installed.

i have installed
libmcrypt-2.4.20
and
mcrypt-2.5.10

with the php-configure script option
--with-mcrypt=/usr/local/include 

the prefix from mcrypt and libcrypt is /usr/local

i have no id but in the php config.log is this message

cannot find -lgssapi_krb5
but on my suse i have no libgssapi_krb5

Thanks a lot for help

Best reagards 
Achim
 [2002-04-19 22:15 UTC] sniper@php.net
How did you install the c-client? From RPM? Compiled
it yourself from sources? iirc, RH rpms have kerberos support buildin their c-client rpms and thus, you NEED
to have the kerberos stuff installed too. This includes
the -dev packages too.

 [2002-04-20 07:30 UTC] achim at altmann dot li
Hallo,
at the first, thanks a lot for all your help's.

How did you install the c-client? From RPM?
NO, i need no kereberos, that was the id to installed the source-files and compiled.

I have test the make-run with the folloes options
make lrh (ha ha ===> need kereberos)

with

make lnp SSLTYPE=unix
compiling php- error
with
make slx SSLTYPE=unix PASSWDTYPE=pam
compiling php-error

in this Night i have test with php-4.2.0RC4
(without kerberos)
the configure was very good
then come the first error
the c-client was not complete
Is crazzy, i have copy all the files in user/local/lib and include was stay in php-manual

Then i have write a message to c-client-mailinglist
In this FAQ stay this my compile from c-client this run was very ok.
I have no id was the make file doing. i think the makefile can not control was is imap-c-client and was is cyrus.

Pleas help

Thanks a lot for help
Best reagards
 [2002-04-20 11:24 UTC] sniper@php.net
I think the documentation needs to be updated as the imap-2001a found here:
 
  ftp://ftp.cac.washington.edu/imap/imap.tar.Z

Has some changes to which header files are needed.
Here is my make line for the imap stuff:

# make slx SSLTYPE=unix SSLDIR=/www/openssl-0.9.6c/ssl/ SSLINCLUDE=/www/openssl-0.9.6c/include/ SSLLIB=/www/openssl-0.9.6c/lib/

And this is how I installed the files:

# cp c-client/c-client.a /www/imap-2001a/lib/libc-client.a
# cp c-client/*.h /www/imap-2001a/include/

And this is how I configured PHP:

# ./configure --with-imap=/www/imap-2001a/ --with-imap-ssl=/www/openssl-0.9.6c/

And it configured, compiled and worked just fine.
I also tried the 'make lnp...' target and that worked also
without any problems.

Please try with these yourself. Just remember to change the
paths to be correct in your system. I will update the
online documentation now.

--Jani

 [2002-05-21 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 14:01:29 2024 UTC