php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16650 PHP Configuration does't work fine for Apache2
Submitted: 2002-04-17 01:28 UTC Modified: 2002-04-17 06:17 UTC
From: elvis dot altherr at elvisaltherr dot ch Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: RedHat 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: elvis dot altherr at elvisaltherr dot ch
New email:
PHP Version: OS:

 

 [2002-04-17 01:28 UTC] elvis dot altherr at elvisaltherr dot ch
PHP 4.2RC4 Config:

cd /usr/src/php-4.2.0RC4

./configure --with-mysql --with-apxs

make 

make install

--> works fine

php Execution from shell is ok (p.a php test.php)

Apache 2.0.35 Config:

cd /etc/httpd/conf

gedit httpd.conf

--> uncomment Section "LoadModule php4_module /usr/lib/libphp4.so

--> restart httpd Daemon

Error: Can't load /usr/lib/apache/php4lib.so into server
undefined symbol "ap_block_alarms"






Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-17 06:17 UTC] sander@php.net
You need to configure PHP --with-apxs2 to build the Apache 2 module!
 [2002-04-18 00:06 UTC] elvis dot altherr at elvisaltherr dot ch
Hi Mr/Mrs Sander

Thanks for your help

it works now fine

regards

E.Altherr
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 02:03:35 2021 UTC