php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1665 Can't logon and execute SQL statements on an identified database instance !
Submitted: 1999-07-05 16:20 UTC Modified: 2006-07-17 08:50 UTC
From: wsb at dc dot ufscar dot br Assigned:
Status: Closed Package: OCI8 related
PHP Version: 3.0.11 OS: Linux RedHat 5.2 and 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wsb at dc dot ufscar dot br
New email:
PHP Version: OS:

 

 [1999-07-05 16:20 UTC] wsb at dc dot ufscar dot br
 Hi Folks,

I made two simple php3 files just to delete all data in a table called "testeoci" in an Oracle 8.0.5 database instance. Both work fine when i call them using the shell prompt but neither work when i call it via a Web Browser ! My Web Server is an Apache 1.3.6 and my PHP version is 3.0.11. Apache is running as "apache" user and i run the files on the same account ( as apache user ). I can't figure out what could be wrong since all the variables are correctly set. Maybe it is really a bug !

The files code are listed bellow :

//Test file #1

<?php

$conn = ocilogon("user","user_pass","ORACLE_SID");

$stmt = ociparse($conn, "delete from testeoci");
ociexecute($stmt);
ocilogoff($conn);

?>


//Test file #2

<?php

$conn = ora_logon("user@ORACLE_SID", "user_pass");
$cursor = ora_open($conn);
ora_parse($cursor, "delete from testeoci");
ora_exec($cursor);
ora_logoff($conn);

?>

Notes : 1 - Everything seems okay with oracle 'cause i can connect with the related database using the sqlplus program. So, the files 'tnsnames.ora' and 'listener.ora' are ok !
           2 - I have a web site running php3 scripts which connects successfully with an Oracle database, but they use the regular logon statement (which works fine !) : $conn = ora_logon("user@hostname", "user_pass"); 
           3 - I've tested it over RedHat 5.2 and 6.0 producing the same results !

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-07-10 12:13 UTC] thies at cvs dot php dot net
please make sure that ORACLE_HOME and ORACLE_SID are set in the environment BEFORE you start apache.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Mar 24 15:01:26 2019 UTC