php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16629 php_flag not working and php_value strange behavior
Submitted: 2002-04-16 04:44 UTC Modified: 2002-05-17 01:21 UTC
Votes:10
Avg. Score:4.4 ± 0.7
Reproduced:8 of 8 (100.0%)
Same Version:4 (50.0%)
Same OS:3 (37.5%)
From: katana at katana-inc dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: katana at katana-inc dot com
New email:
PHP Version: OS:

 

 [2002-04-16 04:44 UTC] katana at katana-inc dot com
I was attempting to modify register_globals value in my vhost config file like i used to do with PHP 4.1.X + Apache 1.3:

php_value register_globals On / Off

It didn't work with PHP 4.2.0 RC/3 even if i didn't get any error message (the value just didn't get changed)

i tried using php_flag register_globals On / Off, but i got an error message when attempting to restart apache:

Invalid command 'php_flag', perhaps mis-spelled or defined by a module not included in the server configuration

Same thing with php_admin_flag

I had to use php_value register_globals 1 / 0 to get it to work.

I'm running Apache 2.0.35 on Windows XP professional, with PHP 4.2.0 RC/3.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-16 05:50 UTC] pryde at oldworld dot de
same here on win2k, php 4.2.0 rc4
 [2002-04-24 17:11 UTC] henrik dot gebauer at web dot de
I have the same problem under Windows 98 SE (Apache 2.0.35) and the FINAL RELEASE of PHP 4.2.0.
 [2002-04-26 17:47 UTC] rubberneck at wwisp dot com
Same problem on Linux machine running apache 2.0.35 with FINAL release of php 4.2.0
 [2002-04-28 22:04 UTC] jmt at twilley dot org
I also have this problem under FreeBSD with Apache 2.0.35 and PHP/4.3.0-dev, and I have a working patch.  I don't know where to sedn it or how to attach it.  If someone could email me where to send it, I'll send it.
 [2002-05-04 01:43 UTC] sabiokah at videotron dot ca
got no error message by adding 
<IfModule mod_php4.c>
  php_flag register_globals on
</IfModule>
However.. it has no effect at all.

I tried to change the name for mod_php4.c to php4_module
,mod_php3.c,mod_php42.c but it seem that since with 
apache2 we dont need to specify AddModule mod_php4.c
I dont know if its appache that doesnt go in the If Statement or if it is the php module that ignore the 
apache directive.

It only work with php_value outside the if statement. 
as mentionned by katana.


Im using Linux-Apache2.0.35 with php4.2.0
 [2002-05-10 03:12 UTC] plamendp at bgstore dot com
The same here:

FreeBSD 4.6-PRERELEASE (~ 01 May 2002)
PHP 4.2.0
Apache 2.0.35

php_flag in .htaccess produces an error by means of unrecognized command or something.

php_value works fine.

regards
 [2002-05-16 03:34 UTC] php at rawhide dot cjb dot net
Same.

Win XP
Apache 2.0.35
PHP 4.2.1
 [2002-05-17 01:21 UTC] jwoolley@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.

I just applied a patch for this.  Thanks for the report!

The patch is at http://cvs.php.net/diff.php/php4/sapi/apache2filter/apache_config.c?r1=1.20&r2=1.21&ty=u
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 04:03:37 2021 UTC