php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16598 Cannot load libphp4.so: undefined symbol: ap_block_alarms
Submitted: 2002-04-14 11:35 UTC Modified: 2003-02-09 23:32 UTC
From: roman at oxic dot net Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: linux red hat 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roman at oxic dot net
New email:
PHP Version: OS:

 

 [2002-04-14 11:35 UTC] roman at oxic dot net
Hello,

resources:
1. php-4_2_0RC3
2. mysqld  Ver 3.23.49a for pc-linux-gnu on i686 (rpm)
3. [root@oxic bin]# httpd -v
   Server version: Apache/2.0.35
--------------------------------------------------
configuration path:
[root@micho conf]# ./configure --with-mysql --with-apxs2=/usr/local/apache2/bin/apxs
--------------------------------------------------
Apache:
[root@micho conf]# grep -i php httpd.conf
#php
AddType application/x-httpd-php .php
LoadModule php4_module /usr/local/apache2/libexec/libphp4.so
LoadModule php4_module /usr/local/apache2/modules/libphp4.so
--
ll /usr/local/apache2/libexec/libphp4.so
-rwxr-xr-x    1 root     root      1349206 mar  9 00:05 /usr/local/apache2/libexec/libphp4.so

when I try start Apache server then system returns me message:

[root@micho bin]# ./apachectl startssl
Syntax error on line 989 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/libexec/libphp4.so into server: /usr/local/apache2/libexec/libphp4.so: undefined symbol: ap_block_alarms
./apachectl startssl: httpd could not be started

---

[root@micho libexec]# ldd -d libphp4.so
        libpam.so.0 => /lib/libpam.so.0 (0x40145000)
        libssl.so.2 => /lib/libssl.so.2 (0x4014d000)
        libcrypto.so.2 => /lib/libcrypto.so.2 (0x4017a000)
        libdl.so.2 => /lib/libdl.so.2 (0x4023d000)
        libltdl.so.3 => /usr/lib/libltdl.so.3 (0x40242000)
        libpspell-modules.so.1 => /usr/lib/libpspell-modules.so.1 (0x40248000)
        libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x4024a000)
        libc.so.6 => /lib/libc.so.6 (0x4028c000)
        libz.so.1 => /usr/lib/libz.so.1 (0x403c1000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x403cf000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x403e2000)
        libmm.so.11 => /usr/lib/libmm.so.11 (0x403ff000)
        libpspell.so.4 => /usr/lib/libpspell.so.4 (0x40404000)
        libgmp.so.3 => /usr/lib/libgmp.so.3 (0x4041e000)
        libgd.so.1.8 => /usr/lib/libgd.so.1.8 (0x4043f000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x40471000)
        libdb-3.2.so => /lib/libdb-3.2.so (0x4050f000)
        libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x405b6000)
        libcurl.so.1 => /usr/lib/libcurl.so.1 (0x405bd000)
        libbz2.so.1 => /usr/lib/libbz2.so.1 (0x405d8000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x405e8000)
        libm.so.6 => /lib/libm.so.6 (0x40615000)
        libttf.so.2 => /usr/lib/libttf.so.2 (0x40638000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40662000)
        libpng.so.2 => /usr/lib/libpng.so.2 (0x40696000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x406b7000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x406d6000)
        libgssapi_krb5.so.2 => /usr/kerberos/lib/libgssapi_krb5.so.2 (0x406ed000)
        libkrb5.so.3 => /usr/kerberos/lib/libkrb5.so.3 (0x40701000)
        libk5crypto.so.3 => /usr/kerberos/lib/libk5crypto.so.3 (0x40759000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x4076a000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
        libcom_err.so.3 => /usr/kerberos/lib/libcom_err.so.3 (0x4076d000)
undefined symbol: ap_block_alarms       (./libphp4.so)
undefined symbol: ap_unblock_alarms     (./libphp4.so)
undefined symbol: ap_user_id    (./libphp4.so)
undefined symbol: ap_server_root        (./libphp4.so)
undefined symbol: ap_group_id   (./libphp4.so)
undefined symbol: ap_user_name  (./libphp4.so)
undefined symbol: top_module    (./libphp4.so)
undefined symbol: ap_max_requests_per_child     (./libphp4.so)

**************************************************

I really have no idea how to fix it ..
Any suggestions ?

thank you very much
Roman

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-14 14:18 UTC] sniper@php.net
There is no such symbol in Apache2.
You've somehow mixed up apache 1.3.x stuff with Apache2..
Why do you load two modules? In Apache2 the DSOs are in 
modules/ directory..

--Jani

 [2002-04-14 15:29 UTC] roman at oxic dot net
Thanks, my stupid mistake ...

now http.conf for php looks like:

#php
AddType application/x-httpd-php .php
LoadModule php4_module /usr/local/apache2/modules/libphp4.so

and it's working :)

thanks again!

Roman
 [2003-02-09 23:32 UTC] magnus@php.net
Just for the record.. 
Not a PHP problem => Bogus.. 
 [2014-02-20 06:09 UTC] cahuza at hotmail dot com
Español:
No es un problema de PHP. El problema es un error en Apache 2.4. Se renombro una estructura de datos interna de unixd_config a ap_unixd_config. Desinstalar Apache 2.4 a Apache 2.2 y problema solucionado.

Inglés:
Not a problem in PHP. The problem is a bug in Apache 2.4. Internal data structure of a ap_unixd_config unixd_config is renamed. Uninstall Apache 2.4 to Apache 2.2 and problem solved.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 06:03:16 2021 UTC