|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16425 Undefined symbol in
Submitted: 2002-04-04 05:11 UTC Modified: 2002-04-22 23:40 UTC
From: mike at tamro dot ru Assigned:
Status: Closed Package: Apache related
PHP Version: 4.1.2 OS: RH 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: mike at tamro dot ru
New email:
PHP Version: OS:


 [2002-04-04 05:11 UTC] mike at tamro dot ru
I was trying to upgrade PHP from 3 to 4; downloaded 
php-4.1.2 from, then did as was discribed in manual. Compilation/installation gave OK responce.
Conf string: ./configure --with-apxs=... --with-pgsql=...

Strting apache gave an error like 
Undefined symbol "pcre_XXX" in
I've checked that i've got no pcre lib installed. So, i did
install it. Then i've listed some reports here and tried the solution like updating Makefile after "./configure"
adding parameter -lpcre to ld commandline.
Nothing changed (just another "pcre_XXXX was reported).
I've added -lpcreposix - the same.
I've adder --without-pcre-regex option to configure.
Again the same, but now:
php_pcre_replace reported as undefined symbol (was
I've downloaded the latest 1.x Apache (1.24) and installed
it. Then tried again - nothing changed.
What was i doing wrong ???


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-04 07:07 UTC]
Try PHP 4.2.0 RC2 from
Also, add the full configure line you have used.
And how did you configure apache?

 [2002-04-22 23:40 UTC]
Reopen if you get this problem with PHP 4.2.0.


PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Nov 29 00:01:26 2023 UTC