php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16403 datetime field error
Submitted: 2002-04-03 00:21 UTC Modified: 2002-04-23 15:54 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: lhling_99 at yahoo dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.5 OS: windows NT 4.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: lhling_99 at yahoo dot com
New email:
PHP Version: OS:

 

 [2002-04-03 00:21 UTC] lhling_99 at yahoo dot com
I'm using PHP 4.0.5 with Microsoft SQL Server 6.5 in Windows NT 4.0 platform.

 When I try to select a "datetime" field in a record, the result is a
   truncated date like "Oct 10 2".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-03 08:42 UTC] sniper@php.net
reclassified
 [2002-04-03 19:54 UTC] lhling_99 at yahoo dot com
what does it mean by "reclassified" ?
 [2002-04-23 14:07 UTC] mbretter at jawa dot at
one of the latest version of php_mssql.c php_mssql.h have a patch for this problem, because the function dbconvert() of the MSSQL-Client-Api wich is used for converting the datetime-values does wired things.

There is a new option in the php.ini called mssql.datetimeconvert if set to Off then the datetime values are returned in the format YYYY-MM-DD HH:MM:SS.

This patch is also in php4.2
 [2002-04-23 15:54 UTC] sniper@php.net
Please try PHP 4.2.0 and reopen if this problem still exists
in it.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 03:03:50 2022 UTC