php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16331 Running phpinfo() kills Tomcat
Submitted: 2002-03-28 15:12 UTC Modified: 2003-10-30 21:10 UTC
Votes:36
Avg. Score:4.9 ± 0.7
Reproduced:31 of 32 (96.9%)
Same Version:16 (51.6%)
Same OS:21 (67.7%)
From: okapi at yahoo dot com Assigned:
Status: Wont fix Package: Servlet related
PHP Version: 4CVS OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: okapi at yahoo dot com
New email:
PHP Version: OS:

 

 [2002-03-28 15:12 UTC] okapi at yahoo dot com
I'm running Tomcat 4.0.3 with PHP 4.1.2 as a servlet. Running Sun JDK/JRE v1.4. When I run phpinfo() on a test page, it returns part of the information with no graphics and shortly after crashes. This happens every time I run it.

Starting service Tomcat-Standalone
Apache Tomcat/4.0.3
Starting service Tomcat-Apache
Apache Tomcat/4.0.3
<tr valign="top" bgcolor="#cccccc"><td align="left">
<p>
This program is free software; you can redistribute it and/or modify it under th
e terms of the PHP License as published by the PHP Group and included in the dis
tribution in the file:  LICENSE
</p>
<p>This program is distributed in the hope that it will be useful, but WITHOUT A
NY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
 A PARTICULAR PURPOSE.
</p>
<p>If you did not receive a copy of the PHP license, or have any questions about
 PHP licensing, please contact license@php.net.
</p>
</td></tr>
</table><br>
</body></html>GIF89a?GIF89ad
An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : EXCEPTION_ACCESS_VIOLATION occurred at PC=0xB7C84F3
Function=zend_hash_index_update_or_next_insert+0x33
Library=C:\Program Files\Apache Tomcat 4.0\php\ext\php4ts.dll

Current Java thread:
        at net.php.reflect.setResultFromObject(Native Method)
        at net.php.reflect.setResult(reflect.java:105)
        at net.php.servlet.readCookies(servlet.java:79)
        at net.php.servlet.send(Native Method)
        at net.php.servlet.service(servlet.java:162)
        at net.php.servlet.service(servlet.java:180)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:247)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:193)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
alve.java:243)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:566)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.jav
a:472)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)

        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
alve.java:190)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:566)
        at org.apache.catalina.valves.CertificatesValve.invoke(CertificatesValve
.java:246)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:564)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.jav
a:472)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)

        at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:
2343)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
ava:180)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:566)
        at org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatche
rValve.java:170)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:564)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
ava:170)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:564)
        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:
468)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:564)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.jav
a:472)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)

        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
ve.java:174)
        at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline
.java:566)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.jav
a:472)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)

        at org.apache.catalina.connector.http.HttpProcessor.process(HttpProcesso
r.java:1012)
        at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.ja
va:1107)
        at java.lang.Thread.run(Thread.java:536)

Dynamic libraries:
0x00400000 - 0x00406000         C:\j2sdk1.4.0\bin\java.exe
0x77F80000 - 0x77FFB000         C:\WINNT\System32\ntdll.dll
0x77DB0000 - 0x77E0C000         C:\WINNT\system32\ADVAPI32.dll
0x77E80000 - 0x77F35000         C:\WINNT\system32\KERNEL32.DLL
0x77D40000 - 0x77DB0000         C:\WINNT\system32\RPCRT4.DLL
0x78000000 - 0x78046000         C:\WINNT\system32\MSVCRT.dll
0x6D330000 - 0x6D442000         C:\j2sdk1.4.0\jre\bin\client\jvm.dll
0x77E10000 - 0x77E74000         C:\WINNT\system32\USER32.dll
0x77F40000 - 0x77F7C000         C:\WINNT\system32\GDI32.DLL
0x77570000 - 0x775A0000         C:\WINNT\System32\WINMM.dll
0x6D1D0000 - 0x6D1D7000         C:\j2sdk1.4.0\jre\bin\hpi.dll
0x6D300000 - 0x6D30D000         C:\j2sdk1.4.0\jre\bin\verify.dll
0x6D210000 - 0x6D228000         C:\j2sdk1.4.0\jre\bin\java.dll
0x6D320000 - 0x6D32D000         C:\j2sdk1.4.0\jre\bin\zip.dll
0x6D2D0000 - 0x6D2DD000         C:\j2sdk1.4.0\jre\bin\net.dll
0x75050000 - 0x75058000         C:\WINNT\System32\WSOCK32.dll
0x75030000 - 0x75043000         C:\WINNT\System32\WS2_32.DLL
0x75020000 - 0x75028000         C:\WINNT\System32\WS2HELP.DLL
0x74FD0000 - 0x74FEF000         C:\WINNT\system32\msafd.dll
0x75010000 - 0x75017000         C:\WINNT\System32\wshtcpip.dll
0x10000000 - 0x10006000         C:\Program Files\Apache Tomcat 4.0\php\ext\phpsr
vlt.dll
0x0B720000 - 0x0B855000         C:\Program Files\Apache Tomcat 4.0\php\ext\php4t
s.dll
0x77A50000 - 0x77B46000         C:\WINNT\system32\ole32.dll
0x779B0000 - 0x77A4B000         C:\WINNT\system32\OLEAUT32.dll
0x1F7D0000 - 0x1F804000         C:\WINNT\System32\ODBC32.dll
0x76B30000 - 0x76B6E000         C:\WINNT\system32\comdlg32.dll
0x70BD0000 - 0x70C1C000         C:\WINNT\system32\SHLWAPI.DLL
0x71700000 - 0x7178A000         C:\WINNT\system32\COMCTL32.DLL
0x782F0000 - 0x7852F000         C:\WINNT\system32\SHELL32.DLL
0x1F8C0000 - 0x1F8D6000         C:\WINNT\System32\odbcint.dll
0x77920000 - 0x77943000         C:\WINNT\system32\imagehlp.dll
0x72A00000 - 0x72A2D000         C:\WINNT\system32\DBGHELP.dll
0x690A0000 - 0x690AB000         C:\WINNT\System32\PSAPI.DLL

Local Time = Thu Mar 28 15:10:48 2002
Elapsed Time = 40
#
# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Client VM (1.4.0-b92 mixed mode)
#
# An error report file has been saved as hs_err_pid1244.log.
# Please refer to the file for further information.
#

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-20 08:29 UTC] sniper@php.net
updated PHP version..propably should change that to infinite since there aren't any developers even trying to fix the
servlet sapi..

 [2003-10-30 21:10 UTC] sniper@php.net
This will be revisited in PHP 5 at earliest. Will not be fixed in PHP 4.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 28 22:01:25 2020 UTC