php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16310 magic_quotes_runtime
Submitted: 2002-03-27 10:09 UTC Modified: 2002-08-20 01:00 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: olivier dot remy at ecolo dot be Assigned:
Status: No Feedback Package: Reproducible crash
PHP Version: 4.1.2 OS: Win NT 4.0 SP6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: olivier dot remy at ecolo dot be
New email:
PHP Version: OS:

 

 [2002-03-27 10:09 UTC] olivier dot remy at ecolo dot be
Quand, dans php.ini, j'?cris : 
     magic_quotes_runtime = On
mes requ?tes SQL me renvoient ceci :
     19     pol▓     ert??      Faisa
puis PHP plante et il m'est impossible de red?marrer le sevice (je dois red?marrer la machine)

Par contre quand dans php.ini, j'?cris : 
     magic_quotes_runtime = Off
mes requ?tes SQL me renvoient :
     19     polo      ertyt      Faisan 
(ce qui est correct)

J'utilise Win NT4, MSSQL7, IIS

Ce probl?me n'est jamais arriv? avec la version 4.0.6 mais il arrive toujours avec 4.1.1 et 4.1.2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-27 10:32 UTC] mfischer@php.net
English please.
 [2002-03-27 11:27 UTC] olivier dot remy at ecolo dot be
When, in php.ini, I do : 
     magic_quotes_runtime = On
my SQL request send this :
     19     pol▓     ert??      Faisa
(bad answeer)
then PHP bug (html files OK but PHP files not OK ; error 500) and it's impossible to reboot the service (I must reboot the computer)

But, when, in php.ini, I do : 
     magic_quotes_runtime = Off
my SQL request send :
     19     polo      ertyt      Faisan 
(correct answeer)

I use Win NT4, MSSQL7, IIS

This bug was not in version 4.0.6 but it is in 4.1.1 et 4.1.2
 [2002-06-17 20:37 UTC] sniper@php.net
Does this happen with this snapshot:

http://snaps.php.net/win32/php4-win32-latest.zip

 [2002-07-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-07-18 03:29 UTC] olivier dot remy at ecolo dot be
This bug is always present in the last version (4.2.1)
 [2002-07-18 04:41 UTC] sniper@php.net
But the question was, whether it's present with this
snapshot:

http://snaps.php.net/win32/php4-win32-latest.zip

(as it should be fixed now)

Remember to replace all the existing PHP files with the
ones found in that package.

 [2002-08-20 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 16:01:27 2020 UTC