php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16281 Constant 'RS_FUNCTIONPATH' changes value
Submitted: 2002-03-26 05:01 UTC Modified: 2002-03-26 05:45 UTC
From: f dot vulto at re-base dot com Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.1.1 OS: FreeBSD 4.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: f dot vulto at re-base dot com
New email:
PHP Version: OS:

 

 [2002-03-26 05:01 UTC] f dot vulto at re-base dot com
Using the following scriptfile 'test.php':

   <?php
     define('RS_FUNCTION'     , 'x');
     define('RS_FUNCTION_PATH', 'x');
     define('RS_FUNCTIONPATH' , 'x');
     define('RS_TEST'         , 'x');
   ?>
   <html>
     <head><title>RS_FUNCTIONPATH</title></head>
     <body>
       RS_FUNCTION: <?php print constant('RS_FUNCTION'); ?><br>
       RS_FUNCTION_PATH: <?php print constant('RS_FUNCTION_PATH'); ?><br>
       RS_FUNCTIONPATH: <?php print constant('RS_FUNCTIONPATH'); ?><br>
       RS_TEST: <?php print constant('RS_TEST'); ?><br>
     </body>
   </html>

One would expect the following output at all times:

   RS_FUNCTION: x
   RS_FUNCTION_PATH: x
   RS_FUNCTIONPATH: x
   RS_TEST: x

But when I keep refreshing the page (holding the F5-key down in Internet Explorer), within 30 seconds the constant 'RS_FUNCTIONPATH' starts changing value to 'csmFirstond' or 'PATHNCTIONPAT':

   RS_FUNCTION: x
   RS_FUNCTION_PATH: x
   RS_FUNCTIONPATH: PATHNCTIONPAT
   RS_TEST: x

It's only the constant with the exact name 'RS_FUNCTIONPATH'; the others constants don't change but are there for comparison.  I haven't been able to reproduce this problem on FreeBSD/PHP 4.0.6 or Windows 98/PHP 4.1.1.  The PHP configuration on the offending FreeBSD server is this:

 './configure' '--with-mysql=/system/mysqld' '--with-apache=../apache_1.3.23/' '--enable-track-vars' '--enable-ftp' '--enable-xslt' '--with-xslt-sablot' '--with-sybase=/usr/local/freetds' '--with-dom' '--with-zlib-dir=/usr/include/'


Freddy Vulto

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-26 05:45 UTC] f dot vulto at re-base dot com
The constant 'RS_CLASSPATH' suffered the same problem; it also changed value.  Since we had been using both 'RS_FUNCTIONPATH' and 'RS_CLASSPATH' I got suspicious and decided to restart the Apache deamon with PHP compiled in it and the problem disappeared.  Very strange though.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 21:01:26 2020 UTC