php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16266 gmdate('U') is the same as date('U')
Submitted: 2002-03-25 14:06 UTC Modified: 2002-03-25 18:44 UTC
From: pcornelius at managestar dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.1.1 OS: Linux 2.4.2-2 i686
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pcornelius at managestar dot com
New email:
PHP Version: OS:

 

 [2002-03-25 14:06 UTC] pcornelius at managestar dot com
The gmdate() function returns the system's local time when used with the 'U' format option.  I've reproduced this on a couple of Linux systems (2.4.2 and 2.4.7 i686 systems).  Both of them function correctly when 'date' is called from the command line.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-25 18:44 UTC] pcornelius at managestar dot com
D'oh!  So it was my expectations that were broken, not the function.  Thanks to Brian Foddy for pointing out that Unix Epoch is seconds since Jan 1 1970, GMT so timezone is meaningless and date/gmdate are equivalent with 'U'.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 14:01:33 2024 UTC