php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16251 config.guess returns value incompatible with configure
Submitted: 2002-03-25 04:23 UTC Modified: 2002-06-06 21:04 UTC
From: Pavel dot Zakouril at mff dot cuni dot cz Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.1.2 OS: UnixWare 7.1.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
12 + 26 = ?
Subscribe to this entry?

 
 [2002-03-25 04:23 UTC] Pavel dot Zakouril at mff dot cuni dot cz
Hi !

On UnixWare 7.1.1 config.guess returns value

i486-unknown-sysv5UnixWare7.1.1

, but configure script expects on this operating system value of type
i486-unknown-sysv5uw7.1.1
So --host=i486-unknown-sysv5uw7.1.1 must be specified to get correct configuration on this system. This behavior is at least since PHP 4.0.6 and in 4.2.0RC1 is still present. Probably the same problem is on any version of UnixWare including Caldera OpenUNIX 8. Config.guess should be modified to return e.g. sysv5uw7 (i.e. uw instead of UnixWare).

Pavel

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-25 04:53 UTC] hholzgra@php.net
problem is in autoconf, not php itself

maybe we could apply manual fixes for releases?
 [2002-03-25 05:12 UTC] cynic@php.net
patches to the faulty third-party tools would be better IMO.
consider a manual fix applied to configure.in (or whatever) in 
a release, and this typical scenario:

"PHP v. X.Y.Z, feature foo doesn't work"
"can you try a snapshot?"
"i can't configure it"
"um, yes. hack configure.in this and that way, and rerun buildconf"

manual "hacks" to released sources would mean much less testing 
IMNSHO.

 [2002-03-25 07:46 UTC] derick@php.net
Can you try 4.2.0rc1 from www.php.net/~derick ? It was build with a newer autoconf (2.52).

Derick
 [2002-03-25 08:21 UTC] Pavel dot Zakouril at mff dot cuni dot cz
This problem is still present also in 4.2.0rc1.

See lines in configure like

sysv5uw[78]* | sysv4*uw2*)
  lt_cv_deplibs_check_method=pass_all
  ;;

This line never match sysv5UnixWare7.1.1, but it should match. Or config.guess should return sysv5uw7.1.1 instead.
 [2002-06-06 21:04 UTC] sniper@php.net
It's the responsibility of the libtool authors to fix this..
You can always try the latest libtool version.
Just do 'libtoolize --force'.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 12:07:37 2022 UTC