php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16172 mail() bug
Submitted: 2002-03-19 14:19 UTC Modified: 2002-03-20 12:35 UTC
From: yaniv at drsbiz dot com Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.1.2 OS: Windows 2000 server
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: yaniv at drsbiz dot com
New email:
PHP Version: OS:

 

 [2002-03-19 14:19 UTC] yaniv at drsbiz dot com
I did a normal installation of PHP.

I'm tring to send email using mail() function and I have no problem sending email to any address except 
anyname@eurocnet.com , it seems that eurocnet.com is not going through. (very strange)

here is an example of the code:

<?
if (!(mail("yaniv@eurocnet.com","test","test")))
 echo "email not sent";
else
 echo "email send";
?>

here is the error message that comes up on the screen:

Warning: Server Error in D:\My WebSite\disconnew\email.php on line 3
email not sentPHP Warning: Server Error in D:\My WebSite\disconnew\email.php on line 3 


good luck
thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-20 06:24 UTC] sander@php.net
It seems your mailserver is blocking that domain. Not a bug in PHP.
 [2002-03-20 12:35 UTC] yaniv at drsbiz dot com
ok, you guys where right thanks for the quick response
This is just another proof why PHP is kicking ASP in the butt
great customer respond

thanks again
Yaniv
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 16:03:35 2021 UTC