php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16170 Apache error fread() fopen()
Submitted: 2002-03-19 13:16 UTC Modified: 2002-07-10 23:56 UTC
Votes:13
Avg. Score:4.9 ± 0.3
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: areyelt at web dot de Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 4.1.2 OS: w2k
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: areyelt at web dot de
New email:
PHP Version: OS:

 

 [2002-03-19 13:16 UTC] areyelt at web dot de
System:
w2k PROF
Apache/1.3.23
PHP 4.12

My Apache crashes with error code:

[Tue Mar 19 19:09:47 2002] [info] master_main: Child processed exited prematurely. Restarting the child process.
[Tue Mar 19 19:09:47 2002] [info] Parent: Created child process 1080
[Tue Mar 19 19:09:47 2002] [info] Parent: Duplicating socket 484 and sending it to child process 1080
[Tue Mar 19 19:09:47 2002] [info] BytesRead = 372 WSAProtocolInfo = 2006620

reason is:

$filename = "d:\\web\\kontakt\\test.jpg";
$fp = fopen($filename, "rb"); 
while(!feof($fp)) { 
  $attachment .= fread($fp, 1024); 
} 
fclose($fp); 

OR: 
$filename = "d:\\web\\kontakt\\test.jpg";
$fd = (fopen($filename, "rb"));
$attachment = addslashes(fread($fd, filesize($filename)));
fclose ($fd);

There's no problem on a Linux System.

What should i do?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-20 06:48 UTC] areyelt at web dot de
i think the problem is filesystme function related
 [2002-07-10 23:56 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 03 21:01:24 2020 UTC