php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16145 Informix Error -439
Submitted: 2002-03-18 09:56 UTC Modified: 2002-05-25 18:35 UTC
From: mauricio at prodesmaq dot com dot br Assigned:
Status: Closed Package: Informix related
PHP Version: 4.0.6 OS: Linux Red Hat
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mauricio at prodesmaq dot com dot br
New email:
PHP Version: OS:

 

 [2002-03-18 09:56 UTC] mauricio at prodesmaq dot com dot br
I am using PHP Version 4.0.6 and Apache 1.3.19 with Informix Dynamic Server Version 7.31.UD1 on Red Hat Linux and the informix error:

-439 - Database server is currently processing an SQL task

occurs eventually when a query is submitted to the database.

Informix company (IBM) was contacted and they sad the error is with PHP.

Configure command:

 './configure' 'i386-redhat-linux' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--prefix=/usr' '--with-config-file-path=/etc' '--disable-debug' '--enable-pic' '--disable-rpath' '--enable-inline-optimization' '--with-apxs=/usr/sbin/apxs' '--with-bz2' '--with-curl' '--with-db3' '--with-dom' '--with-exec-dir=/usr/bin' '--with-gd' '--with-gdbm' '--with-gettext' '--with-jpeg-dir=/usr' '--with-mm' '--with-openssl' '--with-png' '--with-regex=system' '--with-ttf' '--with-zlib' '--with-layout=GNU' '--enable-debugger' '--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-dbase' '--enable-yp' '--enable-wddx' '--without-mysql' '--without-unixODBC' '--without-oracle' '--without-oci8' '--with-pspell' '--with-xml'




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-25 09:14 UTC] derick@php.net
Dup of #14254
 [2002-05-25 18:35 UTC] derick@php.net
The resolution is at #14254
 [2003-06-22 15:12 UTC] shai at shai dot org
I am using AIX4.3.3
Apache 1.3.22
PHP 4.3.1
Infrmx 7.3.1
Same problem, I am using the RS6000-M80 and I can reproduce the problem when I am the only person on the machine with small queries. I suspect that this maybe an apache related issue. I notices that my apache has spawned off 20+ children. So I started messing with the persistant connection and timeout options, seems to have made the problem go away for now. Even with multiple hits, apache doesn't seems to be spawning more than 12 helpers.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 12:01:30 2024 UTC