php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #16041 CGI and EXECUTABLE version produce different results for environment variables
Submitted: 2002-03-13 08:12 UTC Modified: 2002-08-23 22:15 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ferd at twefs dot co dot uk Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.1.2 OS: Windows 2000 + IIS 5
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ferd at twefs dot co dot uk
New email:
PHP Version: OS:

 

 [2002-03-13 08:12 UTC] ferd at twefs dot co dot uk
Upgraded from v4.1.1 to v4.1.2 - using EXE under IIS

Tried to use ISAPI module for IIS as previous versions were still unstable, this version appears better however certain $_SERVER variable go missing, e.g. $_SERVER["PATH_INFO"] is not present when running phpinfo() if using the ISAPI module, but reappears when using PHP.EXE

BTW. Not sure if this happened in 4.1.0 or 4.1.1 as those versions of the ISAPI module would not run very well on my system.

Perhaps the ISAPI module isn't reading the PHP.INI from the same place as PHP.EXE?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-06 05:58 UTC] sander@php.net
Dupe of 7782
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 21 22:03:34 2021 UTC