php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15975 Parse error for lates version of browscap.ini
Submitted: 2002-03-09 16:56 UTC Modified: 2002-11-16 17:08 UTC
From: martijn at hooimeijer-it dot com Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.1.1 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: martijn at hooimeijer-it dot com
New email:
PHP Version: OS:

 

 [2002-03-09 16:56 UTC] martijn at hooimeijer-it dot com
While reading the lates version of browscap.ini (version february 2002) the parser stumbles over brackets.

E.g. an entry like:

platform=Windows XP (Q312461)

will trigger the error: 

PHP: Error parsing e:\PHP\browscap.ini on line 1397

When removing the brackets, e.g.

platform=Windows XP Q312461

the parser does not stumble. Brackets appear on about 10-20 lines in the browscap.ini. It is a drag to remove all the brackets for each and every update of the file. Fix seems to be relatively quick, with a great benefit.

This bug may have a similar cause as bug #10060.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-14 21:20 UTC] iliaa@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

PHP does not support ! | ( ) characters as potential values, to prevent this problem remove those characters from the values of the entries inside your browscap.ini file.
 [2002-11-16 13:19 UTC] adf at sorcerer dot co dot uk
Sorry iliaa@php.net but this is a bug either in PHP or in browscap.ini and is not bogus at all!

The **STANDARD** 4.2.3 windows distribution of PHP (.zip) includes this bug.

The is *NOT* a support request.
 [2002-11-16 13:41 UTC] adf at sorcerer dot co dot uk
Sorry, previous comment should have read "windows binary distribution", don't know about other distributions.

At least I see you have finally accepted this as a bug in the 4.2.3 distribution and have apparently fixed it in CVS (Bug #19902)
 [2002-11-16 17:08 UTC] iliaa@php.net
Not anymore, the file is no longer bundled.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 25 06:03:33 2022 UTC