php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15919 variables_order not works well
Submitted: 2002-03-06 20:21 UTC Modified: 2002-10-24 17:49 UTC
From: mars at abcsolution dot co dot kr Assigned: rasmus (profile)
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.1.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mars at abcsolution dot co dot kr
New email:
PHP Version: OS:

 

 [2002-03-06 20:21 UTC] mars at abcsolution dot co dot kr
One of my PHP pages uses a global variable which gets its value from either HTTP GET data or cookies.

Yesterday I upgraded PHP 4.1.2 from 4.0.1 and found that cookie value prevails GET value for that global variable after hours of debugging. Of course I have variables_order option set to "GPCS".

Why variables_order does not work correctly after I upgrade?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-06 22:12 UTC] yohgaki@php.net
It's known issue.

I guess Rasmus is working for it (not?)
Rasmus, I'll assign to you for now, since you have been posted the issue 
to php-dev.
 [2002-10-24 17:49 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

According to the documentation in the php.ini file:
Registration is done from left to right, newer values override older values.

Meaning that if your variables_order is set to GPCS, the cookie variable with the same name as a GET variable would overwrite the value set by the GET variable.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 00:03:34 2022 UTC