php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15890 MSSQL 2000 with php_mssql.dll - will not function
Submitted: 2002-03-05 18:57 UTC Modified: 2002-06-18 15:38 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: mike at dustsmoke dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.1.1 OS: Windows 2000 advanced server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mike at dustsmoke dot com
New email:
PHP Version: OS:

 

 [2002-03-05 18:57 UTC] mike at dustsmoke dot com
OK, php_mssql.dll will not function on a MSSQL 2000 SP2 server.

I just get timeouts with the smallest SQL querys. Well I just get timouts no matter what.

All I do get is the phpinfo module information that seems fine and shows everything correctly except the 7.0 part.

Looking at the library information it is designed for a version 7... Now I may be wrong here, but, SQL2000 and SQL7 were entirely different engines. SQL7 was a psudo SQL engine more like an ODBC where-as SQL2000 is more of a true SQL engine more like MySQL.

Config, IIS 5, PHP 4.1.1, SQL2000 SP2. (Single box)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-05 23:30 UTC] mike at dustsmoke dot com
OK SOMEPLACE SOMEWHERE, THERE NEEEEEEEDS to be some documentation about this.

you HAVE to do it like this or it won't work and nothing out there has is;

  [MSSQL]
  extension=php_mssql.dll
  mssql.allow_persistent = On
  mssql.max_persistent   = -1
  mssql.max_links = -1
  mssql.min_error_severity = 10
  mssql.min_message_severity = 10
  mssql.compatability_mode = Off

I found this out outta pure accident. Throw it into some module information SOMEPLACE please for the rest of the people out there with MSSQL2000
 [2002-06-04 10:16 UTC] michael dot lidgren at journalistgruppen dot se
Those are the default values i think.
 [2002-06-04 18:17 UTC] mike at dustsmoke dot com
they can't be. it does not work .period. without that info thrown into the PHP.ini file. I can't fathum how many times i've seen it not work with default.
 [2002-06-18 04:53 UTC] derick@php.net
They are the defaults, I just checked.
Closing this, as this is not a bug in PHP.

Derick
 [2002-06-18 15:38 UTC] mike at dustsmoke dot com
Even if you say they are.... Don't you think you should check first? I'm serios when I say I've tried the defaults a million times...... WITHOUT THAT IN PHP.INI IT WILL NOT FUNCTION! I have just under 12 million dollors worth of equipment that I'm working with here guys.
 [2002-06-18 15:39 UTC] mike at dustsmoke dot com
And it looks as thou I can't spell today. ;)
 [2002-09-28 16:50 UTC] bishop6666 at hotmail dot com
es 1 de octubre del 2000 y el php con sql 2000 sigue sin funcionar....
alguien sabe como?
 [2002-09-28 16:50 UTC] bishop6666 at hotmail dot com
es 1 de octubre del 2000 y el php con sql 2000 sigue sin funcionar....
alguien sabe como?
 [2002-11-10 08:56 UTC] etperez at novusca dot com
I am having the same problem. Getting an error out of mssql_connect since I moved from mssql70 to mssql2000. I had found a lot of talking but not solutions!
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 13:01:30 2024 UTC