php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15862 readfile doesn't work correctly with WIndows XP
Submitted: 2002-03-04 13:46 UTC Modified: 2002-05-29 08:53 UTC
Votes:8
Avg. Score:4.5 ± 0.7
Reproduced:7 of 7 (100.0%)
Same Version:5 (71.4%)
Same OS:0 (0.0%)
From: matlanta at mindspring dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.1.1 OS: Windows XP (Professional)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
21 - 9 = ?
Subscribe to this entry?

 
 [2002-03-04 13:46 UTC] matlanta at mindspring dot com
When attempting to use cURL over https, php returns the 
error: "SSL: couldn't create a context!"

Command-line operation in cURL works without error.

A similar situation was reported, and reportedly fixed, in 
4.1.1 CVS, but it has re-appeared in 4.1.2 release. The 
earlier problem was apparently related to compiling SSL 
into both PHP and cURL; I re-complied PHP without SSL but  
the problem persists.

Any work-arounds will be greatly appreciated.

--
Matt Daly

?./configure 
--with-apxs=/usr/local/sbin/apxs 
--with-curl 
--with-config-file-path=/usr/local/etc 
--enable-versioning 
--with-system-regex 
--disable-debug 
--enable-track-vars 
--with-gd=/usr/local 
--with-ttf=/usr/local 
--with-zlib 
--with-mcrypt=/usr/local 
--with-mhash=/usr/local 
--with-mysql=/usr/local 
--with-xml=/usr/local 
--enable-ftp 
--with-gettext=/usr/local 
--enable-sockets 
--enable-trans-sid 
--prefix=/usr/local  


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-11 07:01 UTC] panter01 at ziplip dot com
The problem happens on Linux 2.4.15-pre8, PHP 4.1.2, CURL 7.8.1, openSSL 0.9.6

For me the problem is on a commercial hosted site so I can't recompile or change anything. If you are able to recompile and install things, try getting the latest cURL source release, (7.9.5 as of today). If it still happens with that version of CURL, then add some debug-printf statements into curl/lib/ssluse.c before the call to SSL_CTX_new(req_method) to see what value of req_method is being passed. The context error string is printed out right after this function call.

Steve
 [2002-04-11 07:04 UTC] panther01 at ziplip dot com
Oops, I mistyped email address on last comment.

Steve
 [2002-05-29 08:53 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Oct 21 17:01:27 2019 UTC