php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15843 (crash) save_path problem
Submitted: 2002-03-03 09:21 UTC Modified: 2002-04-10 19:11 UTC
From: vildan at nebulasoft dot com Assigned:
Status: Closed Package: Session related
PHP Version: 4.1.1 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vildan at nebulasoft dot com
New email:
PHP Version: OS:

 

 [2002-03-03 09:21 UTC] vildan at nebulasoft dot com
I am running php 4.1.1 on XP under Apache 1.3.
Every time I call session script, php.exe on server
crashes.

Error msg (in windows):
--------------------------------------------------------
php.exe has encountered a problems and needs to close.
szAppName: php.exe
szAppVer:  0.0.0.0
szModName: php4ts.dll
szModVer:  0.0.0.0
offset:    000a956c
--------------------------------------------------------
I have set the
session.save_path = "C:\windows\temp"
in the php.ini, but the problem persist.


php file content that craches php.exe
---------------------------------------------------------
<?php // creates session for user
      session_start();
      session_register("iwcuser");
      session_register("iwcpass");
      @$iwcuser = $username;
      @$iwcpass = $password; ?>
---------------------------------------------------------

Hope that the problem is within my script, and not PHP
itself, but anyhow, users running their own scripts should be able to crash PHP.

Regards,

-Vildan

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-03 13:30 UTC] vildan at nebulasoft dot com
Hello,


I have tracked down the problem.

Setting session.save_path = "C:\windows\temp" will not fix
the problem.

You will have to create own folder under the root c:\
e.g. "c:\mytemp", using the admin rights (root)

and the set:

session.save_path = "C:\mytemp"


-Vildan
 [2002-04-10 19:11 UTC] sniper@php.net
This bug has been fixed in CVS.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Feb 03 08:05:55 2023 UTC