php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15821 imap_fetchbody fails on subparts
Submitted: 2002-03-01 15:02 UTC Modified: 2002-03-03 18:12 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mike at bigrideau dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.1.1 OS: Windows 2000 SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mike at bigrideau dot com
New email:
PHP Version: OS:

 

 [2002-03-01 15:02 UTC] mike at bigrideau dot com
 imap_fetchbody does not return anything when I try to get a subpart of a multipart message. IE a multipart/mixed message with part 1 text/plain and part 2 with type text/html. If I pass either 1.1 or 1.2 I get an empty string. Passing either 1 or 2 fetches the plain and html parts respectively. Obtaining the struct with or without FT_PREFETCHTEXT makes no difference. I suspect the problem is in the client lib. In looking at the server logs no FETCH request is issued in the 1.1 and 1.2 part cases.

 Mike.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-03 15:12 UTC] mike at bigrideau dot com
No bug, bogus developer.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Oct 16 22:03:34 2021 UTC