php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15819 mysql_fetch_array doesn't return full contents of a varchar column
Submitted: 2002-03-01 13:26 UTC Modified: 2002-03-01 13:29 UTC
From: jh at lohi dot eng dot song dot fi Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.1.2 OS: linux 2.2.19
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jh at lohi dot eng dot song dot fi
New email:
PHP Version: OS:

 

 [2002-03-01 13:26 UTC] jh at lohi dot eng dot song dot fi
i have a table called LOCATION that has a varchar(100) type field called contact.  when i make a query

select contact from LOCATION where (uri LIKE "%901%")

using mysql-navigator, i correctly get the whole string contents of the contact field:

<sip:0333983901@195.10.149.27;user=phone;transport=udp>;expires="Fri, 01 Mar 2002 18:37:13 GMT

but when i make the same query from php, and then apply to the result mysql_fetch_array($result), the contact sting is missing the first part of the string:

<sip:0333983901@195.10.149.27;user=phone;transport=udp>

and only contains the remaining part:

Array ( [0] => ;expires="Fri, 01 Mar 2002 18:37:13 GMT" [contact] => ;expires="Fri, 01 Mar 2002 18:37:13 GMT" )

why is the first part between <>s missing?  is this a bug or
should i do something special because of the <>s?

my php is debian php4 4.1.2-1 and my php-mysql is debian 
php4-mysql4.1.1-2.

-- juha


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-01 13:29 UTC] derick@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 01:15:22 2022 UTC