php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15795 bug in dynamic linker ld.so
Submitted: 2002-02-28 17:14 UTC Modified: 2002-02-28 19:46 UTC
From: joel at netclickz dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.1.2 OS: redhat 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: joel at netclickz dot com
New email:
PHP Version: OS:

 

 [2002-02-28 17:14 UTC] joel at netclickz dot com
Just upgrading from 4.1.1 to 4.1.2, but during the configure stage, this error is featured in the checks.

"checking for mkfifo... BUG IN DYNAMIC LINKER ld.so: dl-minimal.c: 69: malloc: As
sertion `page != ((void *) -1)' failed!
no"

The configure then completes as normal, but i daren't carry on with the make because of the error above.

My configure line is/are:

./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php --with-apxs=/usr/sbin/apxs --enable-track-vars --enable-magic-quotes --disable-debug --with-mcrypt=/usr/local/lib --with-dom=/usr/local/lib --with-pcre --with-zlib --enable-sockets

Any ideas as to what that might be?
Is it safe to continue with the make and upgrade?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-28 19:46 UTC] yohgaki@php.net
This is not a PHP bug, but ld bug.
It seems ld's assertion is failing. Upgrade your ld. (and/or your build tools)


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 06:05:44 2022 UTC