php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15787 --with-apxs=pathtoapxs fails
Submitted: 2002-02-28 12:11 UTC Modified: 2002-02-28 12:54 UTC
From: curtis at maurand dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.1.2 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: curtis at maurand dot com
New email:
PHP Version: OS:

 

 [2002-02-28 12:11 UTC] curtis at maurand dot com
When trying to run configure I call out:
--with-apxs=/usr/local/apache-vip1/bin/apxs 

and configure returns:

1Sorry, I was not able to successfully run APXS.  Possible reasons:

1.  Perl is not installed;
2.  Apache was not compiled with DSO support (--enable-module=so);
3.  'apxs' is not in your path.  Try to use --with-apxs=/path/to/apxs
The output of /usr/local/apache-vip1/bin/apxs follows
Usage: apxs -g [-S <var>=<val>] -n <modname>
       apxs -q [-S <var>=<val>] <query> ...
       apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
               [-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
               [-Wl,<flags>] <files> ...
       apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
       apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Aborting

Now maybe its because I'm not root, but I'm having lots of the same types of problems on a RedHat 7.2 machine even though I am root on that one.  Perl is installed in the /usr/local/lib/perl5.  Also the return from apxs is in the output of the error.  I think the configure script is horribly broken in 4.1.2



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-28 12:54 UTC] sander@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 16:05:46 2022 UTC