php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15757 php4apache.dll not found/valid
Submitted: 2002-02-27 04:51 UTC Modified: 2002-02-27 07:00 UTC
From: verminator2 at hotmail dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.1.1 OS: Win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: verminator2 at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-02-27 04:51 UTC] verminator2 at hotmail dot com
Hi,

I just installed PHP 4.1.1 on my Win2000 which already holds Apache 2.0.32b3. I want to use the DLL provided by the PHP-zip-file from within Apache. Though if I check my httpd.conf with Apache it says that it can't find php4apache.dll in the given path even though it's there. I tried various things like copying the DLLs which came with PHP into system directories but the problem is still there. Btw, I followed the instructions in the install.txt so this should have worked in the first place.

On www.apache.org I found a post that the problem is that that very DLL is probably not supposed to work with the new Apache but with the old one (before 2.0). So my question is when will there be a working php4apache.dll which works with the new Apache-server?

I know this is not really a bug more a question but the problem arose from a bug-like situation and I assume I'm not the only one who'd like to know this. And others may think this is a bug, too, but will find this question here. :)

Regards,
Stefan

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-27 07:00 UTC] sander@php.net
php4apache.dll is for Apache 1.3.x
php4apache2.dll (IIRC) is for Apache 2.x, but it only works for some versions. If you really need it, you should build it yourself from source.
As long as Apache 2.x is not stable, we can't provide you with a reliable php4apache2.dll
 [2002-02-27 22:24 UTC] jobarr at herzeleid dot com
I built it myself and it STILL doesn't work. If i load just phpinfo();, it load fine once. But, the second time Apache crashes.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 18:01:24 2021 UTC