php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15749 PHP (binary) or Apache (module) crashes when session_start() called
Submitted: 2002-02-27 01:07 UTC Modified: 2002-02-27 03:43 UTC
From: tonalsiren at hotmail dot com Assigned:
Status: Closed Package: Session related
PHP Version: 4.1.1 OS: Windows XP Prof Build 2600
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tonalsiren at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-02-27 01:07 UTC] tonalsiren at hotmail dot com
I am running Windows XP Build 2600 with Apache 1.3.23

When I call session_start(), PHP (if configured as CGI) or Apache( if configured as module) crashes.

This will crash the server:
<?php $foo=session_start();if($foo)echo "OK";else echo "NO"; ?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-27 03:43 UTC] sander@php.net
Very likely to be caused by an incorrect session.save_path. This has already been reported and will be fixed in the next release.
Reopen if this is not the case.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 18:03:43 2023 UTC