php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15697 gd support fails to compile
Submitted: 2002-02-24 11:59 UTC Modified: 2002-03-09 16:42 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: mkunze at ambora dot de Assigned:
Status: Closed Package: GD related
PHP Version: 4.0CVS-2002-02-24 OS: linux 2.4.17
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mkunze at ambora dot de
New email:
PHP Version: OS:

 

 [2002-02-24 11:59 UTC] mkunze at ambora dot de
gd support (static) fails to compile.

gd version installed is 2.0.1b, installed in /usr/lib and /usr/include. Did compile on CVS checked out three weeks ago. This seems to be the same error as in bug #15303. I tested CVS snap and CVS checkout, both do fail.

Error messages:

In file included from gd.c:36:
php_gd.h:69: warning: static declaration for `gdImageColorResolve' follows non-static
gd.c:92: conflicting types for `gdIOCtx'
/usr/include/gd_io.h:18: previous declaration of `gdIOCtx'
make[3]: *** [gd.lo] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-24 12:35 UTC] mkunze at ambora dot de
This issue is very likely due to 'configure' not being able to detect gd 2.0.1 correctly.

In php_config.h my gd now is detected as gd 1, while previous versions of configure detected it correctly as gd 2. Because now HAVE_GD15 is not defined, the wrong redefinition of GdioCTX is performed.
 [2002-02-25 10:52 UTC] mkunze at ambora dot de
From the Changelog

2002-02-23  Rui Hirokawa  <rui_hirokawa@ybb.ne.jp>
      [...]
     * ext/gd/config.m4: fixed configure error with freetype1.

The changes introduced by Rui break the recognition of GD 2.0.1 and Freetype2 at least on SuSE Linux 7.3, leading not only to the infamous GdIOCTX bug but also seem to confuse 'configure' (mcrypt version can't be detected). I'm not an autoconf/automake expert, so I can't say what exactly is wrong here, but people hit by this bug should just revert Rui's patch -- everything works fine then...;->...

======revert-gd-patch=================================
--- config.m4   Sat Feb 23 02:36:55 2002
+++ config.m4   Sun Feb 24 14:05:54 2002
@@ -1,5 +1,5 @@
 dnl
-dnl $Id: config.m4,v 1.83 2002/02/23 01:36:55 hirokawa Exp $
+dnl $Id: config.m4,v 1.82 2002/01/13 06:25:18 hirokawa Exp $
 dnl
 
 AC_DEFUN(PHP_GD_JPEG,[
@@ -125,10 +125,6 @@
 AC_DEFUN(PHP_GD_FREETYPE2,[
   PHP_ARG_WITH(freetype-dir, for freetype(2),
   [  --with-freetype-dir=DIR   GD: Set the path to freetype2 install prefix.])
-
-  if test "$PHP_TTF" != "no"; then
-    PHP_FREETYPE_DIR="no"
-  fi
 
   if test "$PHP_FREETYPE_DIR" != "no"; then
     for i in /usr /usr/local $PHP_FREETYPE_DIR; do
 [2002-03-09 16:42 UTC] mkunze at ambora dot de
Rui reverted his patch, so this bug is closed for now
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 10:03:51 2022 UTC