php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15687 include_path at installation misses '.'
Submitted: 2002-02-23 09:17 UTC Modified: 2002-02-23 09:48 UTC
From: chayes at antenna dot nl Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.1.1 OS: windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chayes at antenna dot nl
New email:
PHP Version: OS:

 

 [2002-02-23 09:17 UTC] chayes at antenna dot nl
hi,
i'm trying to support people newly installing the postnuke system (lots of PHP files including each other), and since about the middle january i see several people that just installed  some PHP package with an include path that is empty or contains '..' in stead of '.' .

This way the relative include('file.php') fails, of course.

Unfortunately these people are so 'newbie' that they cannot even reply where they got PHP from. Either here, in a package or in a linux distribution?? Sorry a about that, i realise it does not help much.
One of them had windows... the others didn't tell...

Chris


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-23 09:48 UTC] mfischer@php.net
Anyway, this is no bug with PHP.

The default is to NOT set the include path in any INI file, which then defaults to

  ".:<your-php-install-dir>/lib/php" on Unix systems

and

  "c:\\php4\\pear" on windows systems

Please not that the latter does not require the current path because, well yeah, that's the way it works under windows as we all know.

Just a personal advice: without talking to your users and getting on track where they got their PHP from you have to be a wizard to solve it.

If you're application only depends on 'itself', it may be an option for you to manually set the include_path (if not forbidden by configuration).
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 27 23:03:33 2022 UTC