php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15684 Undefined symbol "pthread_getspecific"
Submitted: 2002-02-23 04:53 UTC Modified: 2002-05-17 07:53 UTC
From: phpbug at markng dot co dot uk Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.1.1 OS: FREEBSD 4.4-STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phpbug at markng dot co dot uk
New email:
PHP Version: OS:

 

 [2002-02-23 04:53 UTC] phpbug at markng dot co dot uk
Configured php4.1.1 (latest from snaps.php.net as of last night)  with options --with-mysql --with-apxs2=/path/to/my/apxs .  Configured, built and installed , but when running apachectl configtest / restart , I get this error.

bash-2.05# apachectl configtest
Syntax error on line 215 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: Undefined symbol "pthread_getspecific"

However, I have rebuilt this after installing gnu portable threads from ports, and using the configure line as follows

bash-2.05# ./configure --with-tsrm-pth --with-mysql --with-apxs2=/usr/local/apache2/bin/apxs

this builds and installs afterwards.

Is this a bug in freeBSD threads , or a bug in php ?

Thanks :)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-23 05:00 UTC] phpbug at markng dot co dot uk
sorry, just checked the version of php, and it's actually PHP/4.2.0 from snaps.php.net :P
 [2002-03-09 13:49 UTC] sniper@php.net
Could you please try the latest CVS snapshot?

 [2002-03-15 04:05 UTC] jon at nsql dot org
this is cross referenced with 14594
 [2002-03-15 09:57 UTC] sniper@php.net
Duplicate of #14594
 [2002-05-17 07:53 UTC] sniper@php.net
this was said to be fixed already in CVS.

 [2002-10-24 14:23 UTC] mbednarik at compeltecomputing dot com
I had the same problem but i resolved it a different way. I installed apache 2.0.43 with
./configure --prefix=/usr/local/apache-2.0.43 --enable-cgi --enable-so --enable-ssl --with-ssl=/usr/local/ssl
then then built it and then installed it. Then in the httpd.conf i added the following lines:
AddType application/php4script .php
Action application/php4script /cgi-bin/php
then download php version 4.2.3 and unpack it then just do a ./configure and then make. After that copy php to /where/your/server/lives/cgi-bin/php and then php will work. I hope this helps for an alternate solution.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 20:01:24 2021 UTC