php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15658 session.save_path directive has no influence on session files save_path
Submitted: 2002-02-21 09:37 UTC Modified: 2002-04-05 06:27 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mrvanes at bigfoot dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.1.1 OS: win2k
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mrvanes at bigfoot dot com
New email:
PHP Version: OS:

 

 [2002-02-21 09:37 UTC] mrvanes at bigfoot dot com
I try to get PHP to save it's session files in the /sessions directory (set session.save_path = e:\sessions) on my document drive, but no matter what I do and how I specify the directory (forward and backward slashes) it keeps saving them in the /tmp directory on that same drive (e:\tmp). There is no reference to /tmp in my whole php.ini file!
From my point of view it looks like the session.save_path directive recognition in the php.ini file is broken.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-22 12:16 UTC] sander@php.net
Did you restart Apache?
 [2002-03-11 06:52 UTC] mrvanes at bigfoot dot com
I use the ISAPI version of PHP (IIS5) and Yes, I restarted that many times to checkt the (mis)behaviour of this directive.
 [2002-04-05 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-04-05 06:27 UTC] sniper@php.net
Try the PHP 4.2.0RC2 from http://www.php.net/~derick/
(and remember to replace php4ts.dll also!)

If you still have problems with it, reopen this bug report.

 [2003-04-15 21:18 UTC] kitdekat at earthlink dot net
I have actually had the same problem with my system running Win2K AdvSrv SP3, Apache2.0.45, PHPv4.3.2-RC (from snaps...).

I have everything working fine except for my sessions. They continuosly want to be stored on '/tmp\...' even though i have modified the php.ini as follows:

NOTE: 
install dir for php is 'w:\var\php'
install dir for apache is 'w:\var\www'
temp folder desired is 'w:\var\www\tmp'

session.save_path = w:\var\www\tmp
session.save_path = w:\var\php\tmp
session.save_path = w:\var\tmp

i have tried all these configurations, but info.php continues to state the my session.save_path is '/tmp'. and yes, i have restarted Apache (multiple times, included complete stop and starts) and even restarted server to remove and cached information. all to no avail.

completely frustratin, since i have everything else on the site up and running, i just can seem to remember what i was running and who i was running it for ;)
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 00:01:29 2024 UTC