php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15626 Max result in ereg
Submitted: 2002-02-19 12:54 UTC Modified: 2002-02-19 13:02 UTC
From: xbouli at hotmail dot com Assigned:
Status: Not a bug Package: Regexps related
PHP Version: 4.0.6 OS: Win 95
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: xbouli at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-02-19 12:54 UTC] xbouli at hotmail dot com
When i try this code , i can't get more than the 9th result.

<?

$string = "abcdefghijklmnopqrstuvwxyz";

ereg ("^(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.)(.).*$", $string, $buffer) ;
print $string."<BR>";
$i=1;
while ($i<20){ 
	print "$i : $buffer[$i]<br>";
	$i++;
}

?>

Thanks.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-19 13:02 UTC] jan@php.net
This is not a bug. Please double-check the documentation available
at http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 09:01:23 2020 UTC