php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1562 fopen() with http:// prefix not working
Submitted: 1999-06-17 16:35 UTC Modified: 1999-06-18 11:51 UTC
From: Justin at HostFacts dot com Assigned:
Status: Closed Package: Performance problem
PHP Version: 3.0.9 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Justin at HostFacts dot com
New email:
PHP Version: OS:

 

 [1999-06-17 16:35 UTC] Justin at HostFacts dot com
After the upgrade from 3.0.7 to 3.0.9, fopen() with an http:// prefix fails. include() with a URL also fails. However, file() works as expected with a URL. This problem occurs with both web based scripts and command line (crontab) scripts.

fopen() works just fine for local files, and occasionally works with a URL - it seems random, as it will work one time and later fail with the same URL. The exact same script works every time without failure using 3.0.7 (a web spider script that runs 24/7).

Also note that many scripts written by various people have had this same problem on our servers since the upgrade.

Thanks,

Justin Nelson, SFE Software

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-06-18 11:51 UTC] sas at cvs dot php dot net
fixed in CVS
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 10:01:25 2020 UTC