|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15612 Constant Refresh when files too large.
Submitted: 2002-02-18 22:51 UTC Modified: 2002-06-10 01:00 UTC
Avg. Score:4.8 ± 0.5
Reproduced:18 of 18 (100.0%)
Same Version:10 (55.6%)
Same OS:12 (66.7%)
From: warrenp at mountaincable dot net Assigned:
Status: No Feedback Package: Output Control
PHP Version: 4.3.0-dev OS: ANY
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: warrenp at mountaincable dot net
New email:
PHP Version: OS:


 [2002-02-18 22:51 UTC] warrenp at mountaincable dot net
Somewhat related to "Bug #14529 script doesn't always finish output".

I just finished writing a script that is 82 Kb big. The script runs fine with no errors but when I converted it to a phps and viewed it, It would constantly refresh inside the window. 

I was able to fix a problem with a similar incident by putting flush() functions in a loop with many many print and echo statements. That fixed that but I can't do that with the phps file.

I have the website availeable if needed.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-18 22:54 UTC] warrenp at mountaincable dot net
now is this a memory limit problem or is it something else?
 [2002-02-19 16:50 UTC] warrenp at mountaincable dot net
Here's some more info about what's going on.

NOTE: Since the websites are being hosted on my computer, if they cannot be accessed it might be that the computer is not on or the port is blocked (port 80 is sometimes blocked by my ISP to keep out the code red virus)

The address is :

In IE6 it would constantly refresh.
In Mozilla and Opera it would load up some of the file and then stop. Once and a while it would load the whole thing but not often.
In Netscape 6 it would only load up part of the file then stop. Netscape 4.78 was the only browser to load up the phps file every time completely. The following is the access log for some of the browsers.

"GET /apply.phps HTTP/1.1" 200 40748 "-" ... IE 6
"GET /apply.phps HTTP/1.1" 200 417309 "" ... Opera
"GET /apply.phps HTTP/1.0" 200 416590 "-" ... Netscape 4.78

I get a similar error with another website.
With this website, they work great on the hosted computer and somewhat worked for network computers. But once I try to access it from the internet, it rarely works. If I get the full page at all, it has some garbage characters in it.

THe flush() worked on one site but when I tried using the flush() on this website, it only made it work for network computers. For computers on the internet, it still wouldn't work. And regarding phps files, I can't use flush() at all.

Let me know if you need any more information.
 [2002-02-24 05:50 UTC]
I think you have segfault. Could you try to run your scripts under Unix like OS and send backtrace?

If you cannot, could you create short script that reproduce this?
 [2002-02-25 22:54 UTC] warrenp at mountaincable dot net
I ran the same thing (apply.phps) under windows 98 and it seemed to work.

Although here is a script that will produce the same result when i host it on XP:

  print "<TABLE NOWRAP BORDER=1>";
  //for ($j = 0; $j < 500; $j++) {
  for ($j = 0; $j < 200; $j++) {
    print "<TR>";
    for ($i=0; $i< 10; $i++)
      print "<TD NOWRAP>Row $j -- Column $i</TD>";
    print "</TR>\n";
  print "</TABLE>";
 [2002-02-26 09:59 UTC]
Hmm. I don't have problem with my linux.
Windows specific may be.

What is your SAPI, IIS, Apache or else?
What is your output_buffer, zlib.output_compression and output_handler
 [2002-02-26 19:27 UTC] warrenp at mountaincable dot net
I tested it out on a windows 98 machine and it seemed to work. At least the apply.phps file.

> What is your SAPI, IIS, Apache or else?

> What is your output_buffer
It was 4096 then i tried On and Off

> zlib.output_compression

> and output_handler settings?
 [2002-02-26 21:17 UTC]
.phps is handled differently and there _is_ known problem ;)

We should get rid of ".phps" support for PHP5 perhaps.

 [2002-03-30 22:57 UTC] kilercris1 at comcast dot net
Hello I have been having the same problem but I didn't realize it was because of the page size.

WindowsXP Pro
Apache 1.3.23
PHP 4.1.2

Also some browsers just show the cut off page, some rapidly refresh
 [2002-03-30 23:03 UTC] kilercris1 at comcast dot net
Oh, and I get this with .php files that have a large output. It didn't happen before when I had PHP 4.06 and Windows ME. It happens sometimes with phpMyAdmin pages too.
 [2002-04-01 01:37 UTC] warrenp at mountaincable dot net
I would like to report that after I had switched to linux, the problem disappeared. I guess it was OS specific.
 [2002-04-02 09:42 UTC] brian at planetblur dot org
I have had this same problem - winXP, php4.  I was getting reports from people that the page would halfway load, then get redirected to a "Page not found" error.  But the url in the address bar was correct.  If the user refreshed, sometimes it would load back up, sometimes it wouldnt.

Reviewing the logs, I would also notice sometimes that the same user would sit there and refresh the same page over and over, about 20 - 30 seconds apart.  After asking them why they did this, they denied ever doing it, and said they just had the page open and didn't notice anything.

There seems to be a lot of different things here happening in this one bug.
 [2002-04-02 20:12 UTC] kilercris1 at comcast dot net
I think it is just 1 bug in PHP but multiple reactions to it from different browsers.
 [2002-04-03 18:36 UTC] christian dot mohn at ergoteam dot no
On my machine, a simple page only consisting of the <?php phpinfo();?> script, it constantly refreshes, sometimes the page isn't properly rendered at all.

I'm running Windows XP (Build 2600), Apache 1.3.23 and PHP 4.1.2. And IE 6.0.

The site is accessible for you guys, if you need to see this. Mail me, and I'll post the link to it.

I first noticed this, after installing Gallery 1.2.5. I have also experienced the "Page/host not found" reply from my webserver, though the link is correct. The correct page flashes on the screen, before the "page not fould" error is displayed.
 [2002-05-03 23:39 UTC]
This should be chunked output problem.
No additional comment is needed unless you know 
exact cause.

 [2002-05-09 02:37 UTC]
I've tried to reproduce under my Linux. I don't have serious problem with chunked otuput. 
Could you snapshot? (Windows build from latest cvs is in there, I think)

BTW, phps will not work well, use show_source() etc.

 [2002-05-26 13:59 UTC] kilercris1 at comcast dot net
It only occurs on WinXP servers and is causing major problems for people using PHP on a WinXP server.  I setup a copy of warrenp's test script on my WinXP server if you need to see it .  IF you leave it alone, an entire copy of the page will eventually load and stop refreshing.  The larger the output the longer it takes for that to happen. Another copy is at that only prints 100 rows.  This one works most of the time, but if you refresh it several times you'll see it refresh rapidly for about a second or you'll get messed up output like "???NOWRAP>Row 81 -- Column 4" sometimes.  I played with my configueration a little and found that this problem doens't occure when output_buffering is turned on in php.ini .  How can I snapshot?
 [2002-06-10 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2007-03-20 09:45 UTC] mehanathans at yahoo dot com
yes, i encountered the same problem with winXP with PHP 4/5. Sometimes, the page loads, sometimes DNS error, sometimes refreshing itself many a times before the previous above 2 results occur. But, I didn't find any problem with win2000 and PHP 4 or 5, only in winXP, this problem occurs.
 [2007-07-05 00:30 UTC] hwijaya at nodens dot biz
Hi All, 

I am running a hosting business, and mostly on Linux. We experienced the same problem periodically to our servers. We had to migrate data to a good server, and after a period of time (weeks/months), the problem came back.

The thing is that, if you are running html or download a file, no problem, but if you are running php on the port 80, the problem is there, if you are running the php on port 443 (SSL), no problem at all. Even if I have upgraded from the current php 4 to php 5, case stands.

This is our existing server that is having problem, but our customer is running https, so so far no complaints.

If you want to see what's inside the output, in your linux box, do "wget", and you will see what I mean, randomly you would get 46K, or 1MB, or 16MB, or any other sizes, and when you open the file, you will see a lot of rubbish at a certain mark.

I really need help to solve this problem, we have to spend sleepless nights just to migrate data to a new server, and then it will happen again still.

This is not Platform issue nor Client Issue.

The log files do not indicate anything, as it is just keep refreshing, I think IE is the one acts smart and refresh the page, because it was disconnected somehow.

Do let me know if you need any information.

PS. We tried to workaround this issue once by using output_buffering, it worked for a server, but not for others.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Mar 05 05:01:29 2024 UTC