php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15580 sapi_apache2.c fails to compile with Apache 2.0.28
Submitted: 2002-02-15 15:26 UTC Modified: 2002-04-06 11:13 UTC
Votes:6
Avg. Score:4.7 ± 0.7
Reproduced:5 of 5 (100.0%)
Same Version:1 (20.0%)
Same OS:1 (20.0%)
From: vfoitzik at gmx dot net Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.0CVS-2002-02-15 OS: Debian 3.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vfoitzik at gmx dot net
New email:
PHP Version: OS:

 

 [2002-02-15 15:26 UTC] vfoitzik at gmx dot net
Hello folks,

today I tried to compile latest PHP with Apache 2.0.28, since PHP 4.1.1 seems to have some variable export problem. Configure goes fine, but make bails out with the following error messages:

make[3]: Entering directory `/data/home/vf/ap2/build/php/sapi/apache2filter'
/bin/sh /home/vf/ap2/build/php/libtool --silent --mode=compile gcc  -I. -I/home/vf/ap2/build/php/sapi/apache2filter -I/home/vf/ap2/build/php/main -I/home/vf/ap2/build/php -I/usr/local/ap2/include -I/home/vf/ap2/build/php/Zend -I/home/vf/ap2/build/php/ext/mysql/libmysql -I/home/vf/ap2/build/php/ext/xml/expat  -D_REENTRANT -I/home/vf/ap2/build/php/TSRM -DTHREAD=1 -g -O2 -pthread -DZTS -prefer-pic  -c sapi_apache2.c
sapi_apache2.c: In function `php_input_filter':
sapi_apache2.c:252: incompatible type for argument 4 of `ap_get_brigade'
sapi_apache2.c:252: too many arguments to function `ap_get_brigade'
sapi_apache2.c:259: incompatible type for argument 4 of `ap_get_brigade'
sapi_apache2.c:259: too many arguments to function `ap_get_brigade'
sapi_apache2.c: In function `php_register_hook':
sapi_apache2.c:471: warning: passing arg 1 of `ap_hook_post_config' from incompatible pointer type
sapi_apache2.c:474: warning: passing arg 2 of `ap_register_input_filter' from incompatible pointer type
make[3]: *** [sapi_apache2.lo] Error 1
make[3]: Leaving directory `/data/home/vf/ap2/build/php/sapi/apache2filter'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/data/home/vf/ap2/build/php/sapi/apache2filter'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/data/home/vf/ap2/build/php/sapi'
make: *** [all-recursive] Error 1

It seems this is the same problem as #11257, but since this is half a year ago ...

Configure options:
./configure --with-apxs2=/usr/local/ap2/bin/apxs

Summary:
Debian sid 3.0, 2.4.17, Apache 2.0.28, PHP 20020215

Thanks in advance
Victor

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-15 15:57 UTC] elixer@php.net
Try the latest CVS version of Apache2 as well.  I built 2 days ago without a problem.  Let me know if that helps.

Sean
 [2002-02-15 18:12 UTC] vfoitzik at gmx dot net
Okay, here we go:

since 2.0.28 didn't work, I tried to compile PHP 20020215 with 2.0.32-alpha and it did at least compile ;-) But this led into another problem. Starting Apache succeeds without php module loaded, but leads to strange behaviour if the module has been enabled. It's hard to explain: the main Apache process is started, but doesn't create any child processes or threads. It doesn't react to signals, nor responds to telnet requests.

Hmm, so I took the latest Apache CVS and simplified all configure options. Same result.

I've no idea where to search for any hints on how to solve this. I know that Apache 2 support in PHP is still under heavy development, but any hints 'd be appreciated. Please let me know if I shall provide further information.

Summary:
Apache latest CVS, vanilla config with php4 enabled
Configure options:
  --with-mpm=worker \
  --prefix=/usr/local/ap2 \
  --enable-module=so
PHP latest CVS, configure options:
  --with-apxs2=/usr/local/ap2/bin/apxs
GNU ld version 2.11.92.0.12.3 20011121 Debian/GNU Linux
gcc 2.95.4
ltmain.sh (GNU libtool) 1.4.2a (1.922.2.79 2001/11/28 21:50:31)

TIA
Victor

 [2002-02-22 16:32 UTC] puterwzzrd at hotmail dot com
Wish I had a sollution but I can only make things worse:

Apache2.0.32(the released beta) and PHP4.1.1 give the same error...
 [2002-02-25 04:35 UTC] cisacchi at cracantu dot it
Same problem with apache 2.0.32 and php 4.1.1 on RedHat 7.2 ( kernel2.4.13).
 [2002-03-11 23:22 UTC] loop at nme dot com
same with Slackware 8.0 + fixes
PHP 4.1.1, 4.1.2, Apache 2.0.32, Linux 2.4.18

Making all in sapi
make[1]: Entering directory `/usr/src/php-4.1.2/sapi'
Making all in apache2filter
make[2]: Entering directory `/usr/src/php-4.1.2/sapi/apache2filter'
make[3]: Entering directory `/usr/src/php-4.1.2/sapi/apache2filter'
/bin/sh /usr/src/php-4.1.2/libtool --silent --mode=compile /usr/src/php-4.1.2/meta_ccld  -I. -I/usr/src/php-4.1.2/sapi/apache2filter -I/usr/src/php-4.1.2/main -I/usr/src/php-4.1.2 -I/usr/local/apache2/include -I/usr/src/php-4.1.2/Zend -I/usr/src/php-4.1.2/ext/mysql/libmysql -I/usr/src/php-4.1.2/ext/xml/expat  -D_REENTRANT -I/usr/src/php-4.1.2/TSRM -DTHREAD=1 -g -O2 -pthread -DZTS -prefer-pic  -c sapi_apache2.c
sapi_apache2.c: In function `php_apache_sapi_register_variables':
sapi_apache2.c:148: warning: initialization discards qualifiers from pointer target type
sapi_apache2.c: In function `php_input_filter':
sapi_apache2.c:247: incompatible type for argument 4 of `ap_get_brigade'
sapi_apache2.c:247: too few arguments to function `ap_get_brigade'
sapi_apache2.c: In function `php_register_hook':
sapi_apache2.c:408: warning: passing arg 2 of `ap_register_input_filter' from incompatible pointer type
make[3]: *** [sapi_apache2.lo] Error 1
make[3]: Leaving directory `/usr/src/php-4.1.2/sapi/apache2filter'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/php-4.1.2/sapi/apache2filter'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/php-4.1.2/sapi'
make: *** [all-recursive] Error 1
 [2002-04-06 11:07 UTC] sniper@php.net
You need latest CVS versions of both PHP and Apache2.
As you propably know, Apache2 is still beta and a moving target..

 [2002-04-06 11:13 UTC] sesser@php.net
Hmmm Apache2 isn't a moving target anymore...
It was released today (wasn't it?)

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Aug 02 21:01:24 2021 UTC