php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15577 "failed to rollback outstanding transactions!" Oracle connection error
Submitted: 2002-02-15 15:14 UTC Modified: 2002-05-24 00:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: ccornutt at catalog dot com Assigned:
Status: No Feedback Package: OCI8 related
PHP Version: 4.1.1 OS: Solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ccornutt at catalog dot com
New email:
PHP Version: OS:

 

 [2002-02-15 15:14 UTC] ccornutt at catalog dot com
I have a function: 
---------------------------------
function SQLreturn($sql){
	$OC = @OCINLogon($this->user,$this->pass,$this->string);
	if($OC){
		$parsed = OCIParse($OC,$sql);
		OCIExecute($parsed);
		OCIFetchInto($parsed, &$rows,OCI_ASSOC);
		OCIFreeStatement($parsed);
		OCILogOff($OC);
		//return the array
		//print_r($rows);
		return $rows;
	}else{
		echo "No SQL connect: return";
	}
}
------------------------------------

that appears to cause some trouble...I'm not sure why either. Other database connections work fine on this same server, but this one keeps giving messages like: 

Warning: failed to rollback outstanding transactions!: Error while trying to retrieve text for error ORA-03113 in
/export/home1/catalog/domainadmin/index.php on line 97

Warning: _oci_close_session: OCISessionEnd: Error while trying to retrieve text for error ORA-12545 in
/export/home1/catalog/domainadmin/index.php on line 97

Has anyone else encountered this one? If so, any idea how to fix it?
thanks,
-chris

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-13 09:16 UTC] thies@php.net
please send me a short fully self-contained testcase.

 [2002-05-24 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-06-08 04:44 UTC] paul at redeye dot com
Similar problem on linux, the big mystery was that it was happening on SELECTs. :
Was using PLogon, tried to commit after every transaction but no change
Changed to non persistent log ons, still no change.
Eventually resolved it by specify OCILogoff after every connection.
Problem seemed to be due to establishing 2 different connections within the same php script.
 [2002-06-08 12:56 UTC] paul at redeye dot com
Ignore my posting, the problem has returned. However, given this error only occurs for us with an application that uses two different connections in the same script that would appear to be a clue.
 [2002-07-10 13:07 UTC] bgrogan at gasou dot edu
I also get the famous ORA - 03113 error when trying to select data from certain tables with a simple script.  Other tables I can select from.  Still troubleshooting this.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 21 21:03:32 2021 UTC